8.0.2 Cannot render in place just one part [BON-6310]

So I could do this before (8.0.1) and now it is impossible to render inplace just one part of a multimbral instrument.

e.g

8 outputs of an instrument and midi tracks connected to each output. If you try and render in place just one part Cubase goes and renders all of them!

With ‘Complete signal Path’ ticked it works as expected and this is the only way to get only the single or selected parts rendered.

Anyone else want to chime in before I take this over to ‘issues’

My thread below yours at the moment, I have no way to see the render-in-place settings any more, and plug-ins are not being rendered to the wav, just copied to the new track that’s created.

Looks like render-in-place in general may be in need of some patching.

Yes same here, also if you have lets say 4 parts with separate outputs/midi and render them all you will get 16 tracks rendered.Like your scenario but it treats each separate channel as all channels of the multi instrument when rendering.

Strangely if you leave them all to the main output it works ( Kontakt 5 latest rev )

Actually its seems completely broken , leaving all on main output does not work. Anybody else have this issue.

This what happens if you render a 4 part Omnisphere multi


pre rendered setup

Omnisphere setup

Yes, Omnisphere is just one example, does exactly the same here with Omnisphere V2.

I have opened an ‘ISSUE’ post. Please copy your screen grabs into that post for the moderators. Support have been made aware and am waiting for confirmation (via email)

http://www.steinberg.net/forums/viewtopic.php?f=230&t=80854

What happens when you solo just one track before rendering?

What happens when you solo just one track before rendering?

makes no difference, all the outputs are rendered. So even with track soloed and just that part selected you get all the outputs rendered!

They have locked that post saying it is the same issue as

http://www.steinberg.net/forums/viewtopic.php?f=231&t=78440

it clearly as this is different and our issue only started in 8.0.2

Thanks for drawing my attention to that Woodsdemis.

I have re submitted the issue and hope that more care is given by the Steinberg team into looking in detail to this issue which is cleary different from [BON-8590]

update:

OOPS, just found the issue in problems and solutions (which I obviously did not read thoroughly enough before). So is this going to be solved Steiberg?

[BON-6310] Using “Render in-place” on VST instruments with multiple active outputs results in files for every active output, also for the ones which do not actively play back any audio. If you want to render only single events or single tracks from a multi-timbral VST instrument source, using individually assigned outputs, make sure to use the render option “complete signal path” or “complete signal path + master fx”. In this case, you’ll only get audio for the selected tracks or events/parts.

Tx
Seems a bit of a fudge, made much more sense the pre 8.0.20 way. The render in place was ideal for VIs and they have now made it more awkward, why can’t it be changed back I wonder?