8th note rest problem in 2/2 meter

I am having a problem getting Dorico to enter 8th note rests correctly, I have tried with and without forced duration.

The rest dialogue is set to “not allow dotted rests” as shown in the screen shot.

I am also getting a quarter rest when there should be 2 8th rests, also seen in the screen shot. This actually makes reading the music more difficult because it does not show the subdivision.

I have gone over and over checking rest dialogues and beam groupings to try and fix. I’m sure it’s probably something simple but I am pulling my hair out trying to get this to display correctly.

I have included 3 screen shots to illustrate my problem, any help would be great.
simple time signatures.jpg
eighth note problem 2.jpg
eighth note problem 1.jpg

It would help us to know what time signature you are using.
(You realize, of course, that example 2 is not a following rest.)

I’m not sure what setting of mine does this, but the settings I use (here in 4/4 time) seem to produce the result you are after.; so Dorico can do this.


Thanks for the reply, as stated in the post title I am using 2/2 meter (at this moment).

I’m not sure what you mean by a following rest in example 2, there should not be a dotted quarter rest, as set up in the rest settings.
I know that Dorico CAN do this, I’m just trying to figure out why it is not at the moment.

As I said before, I’m sure it’s probably me being daft, but no setting I try sorts this out.


The rest setting in your picture only applies to rests at the END of a beat. It is irrelevant for the two examples you gave. In your example 2, the rest is at the START of a beat.

…and surely Force Duration gives you the exact thing you want? Are you in Rest mode?

How did you enter the music? Did it come from an XML import? Have you tried Selecting everything and doing “Reset Appearance”? (Edit menu)

I have tried with and without forced duration, same result. I have tried entering a rest manually and nothing happens.

I entered the music manually, no XML. I tried selecting all and “Reset Appearance”, no fix.

Thanks for the suggestions, I do appreciate the help!

If Force Duration isn’t working for you, you MUST be doing it wrong.

To enter rests with Force Duration you need to use “,” to engage rest input, “O” to engage Force Duration and then any of the following letters to input rests: ABCDEFGY.
Do not use Space - Space does not input anything; it just advances through the existing rests.


I finally figured out how to fix my problem, I went back and entered rests with force duration on and this time it worked.
Now, I’m pretty sure I entered the original with forced entry on also but at least I can fix it now.

The problem is when I go back and try to re-enter this exact same measure manually it still notates it wrong. I tried this with and without forced duration and it notates the same either way, see image for 8th note problem 1.

I ran into problem 2 during my 30-day trial and didn’t understand why there was no option in the settings for always using an eighth rest before an eighth note as well as after an eighth note in 2/2.