8th note time signatures (and other bugs)

Hello, I’m a long time Steinberg user and a first time VST Live user. I’ve been using Cubase for live purposes for a while now, but I figured it was time for an “upgrade” in that department.

I’m trying to program one of my songs, and after importing session data from the Cubase session I saw that VST Live won’t support 8th note time signatures, such as 6/8, 5/8, 7/8, etc. which are very essential in the style of music I use these apps for. I could input the time signature marker but the metronome still gives me a 4/4.

Is there a workaround to this/is this a bug/is this something that will be implemented in the near future? I won’t be able to stop using Cubase for live purposes if the time signature track is not able to give me 8th or 16th note time signatures. Sorry if this has been talked about before, but after a quick scan in the forum I couldn’t find any information on this matter.

Thanks!

Here’s a quick example of what I mean. You can see the “6/8” marker in the signature track, but VST Live is still giving me 4/4 in the metronome. This doesn’t happen in 3/4. I could, in theory, change this to 3/4 but as you can see I have a long list of time signature (and tempo) changes so I would rather not take that route (and also, as a classically trained musician, I tend to notice the difference between a 3/4 and a 6/8 heh).

1 Like

Okay, a small (or maybe not so small) follow-up: it seems that importing “project data” is kinda broken, as I began programming from scratch and VSTLive had no problem with the 6/8. I gasped with relief, as maybe I just needed to not be lazy and do my signature/tempo maps by hand but now I have another issue.

When trying to put a new time signature marker on bar 37 (as pictured below), it always leads me to the first bar. Am I doing something wrong? I’ve spent an hour on this and I feel really dumb for that. For the life of me, I’ve been using DAWs and time signature/tempo maps for years and years and sadly I feel that the implementation of those matters in VSTLive is still in diapers. I know that this is a shiny, brand-new app with a bright future ahead and I’m trying really hard to love it but so far it’s being not so friendly.

Also, another bug that I came across: MIDI import is not working properly. I export a MIDI file from Cubase and when trying to import it via the menu it won’t let me select the .midi file, and when dragging and dropping it says the .midi extension is not supported. WHAAAAAAT. Should I try exporting a type 0 MIDI file instead? Lowering the resolution? Any ideas would be greatly appreciated. I already tried changing the .midi extension to .mid as I’ve had a couple of situations (mainly with old operating systems and devices that do not support a 4 letters extension) in which I’ve changed .midi for .mid to solve this issue. I tried that in here to no avail.

I’m sorry for all the venting. I realize this app is being constructed and perfected as we speak, but I can’t help but feel that some basics (I’d consider MIDI importing something that in paper should be very painless) are not well solved yet. If it helps in any way to know, I’m using a brand-new Mac Studio with M1 Max running macOS Monterey. I already tried running the Intel version via Rosetta only to obtain the same results.

I love Steinberg (I own Cubase, WaveLab and Dorico, so I come from a place of experience and love for this company’s products) and I can’t wait until this app figures all of these things out because I’m going to use the hell out of it but it’s definitely not there yet. At least not for me.

Thank you in advance for reading and for any helpful suggestions. I’ll be very grateful if you show me the way amongst these very silly and time-consuming problems, in case there is one. I want to feel that my money was well invested in this program. :pleading_face:

1 Like

Hello @lalocuramarine,

welcome to VST Live.

I’ve tried to reproduce your problem and can confirm it with the latest VL 1.1.10 version. There will be an update (very) soon. And your problem does not occur anymore. Please wait for the next update and let us know if it working for you.

/Michael.

… no, it’s a bug. But it’s already fixed with the next update.

… I hope we can change that with the next update.

… sorry. The Import menu function does not accept *.midi files. That’s a bug. It will be fixed in the next-next update. Not the very soon one. But it should work when you have changed the file extension to *.mid. But a *.midi file is working if you are dragging it directly to a MIDI Track. Can you please give us the file? Then we can check what is going wrong.

/Michael.

1 Like