9.0.1.113: Groove Agent 4 causing Cubase to crash

Issue description: I’m currently trying to work on a project which contains a VST3 instance of Groove Agent 4.2.30.320. However when I try to load the project it crashes Cubase. When I rename the VST3 instance of Groove Agent, the project loads fine, however the GUI of the VST2.4 Groove Agent substitute is truncated in a small window only showing the Activate, Bypass and Automation buttons. There’s no sound from the VST2.4 instance.

Before the project causing Cubase to crash I also had issues showing the Groove Agent GUI. In an early stage I also had issues showing the Retrologue VST3 GUI. While other VST GUI’s could be opened fine, the Groove Agent or Retrologue GUI did not appear. I solved this by temporarily disabling the Always On Top option in Preferences.

I can not reproduce the issue, because the project file simply is broken and won’t load.

I attached a dmp.

Edit: I now managed to open the project, by first starting a new project and add Groove Agent (that works as expected) and then opening and activating the troublesome project.
Cubase 9.0.1.113 64bit 2016.12.16 2.05.zip (167 KB)

Additional observation: Occasionally I can open the troublesome project. When it does it gives me an error and writes a dmp (I’ll attach that one too).
Right before that happens the Average Load in the ASIO meter clips. From that moment when I try to open the Groove Agent GUI from the VST Instrument Panel, the Average Load clips, but the Groove Agent GUI does not open. It does play back normally.


Cubase 9.0.1.113 64bit 2016.12.16 17.12.zip (135 KB)

Hello,

I split two comments: https://www.steinberg.net/forums/viewtopic.php?f=255&t=108988

I also linked this one to the official issue report, as it might be related. If not, I’m going to create a new issue and update the thread. Thank you.

Hello

first post so sorry if I don’t get the etiquette right .

I have recently experiencing problems with GA4 and cubase pro 9 . I can load Cubase , open a instrument track with GA4 , seems to work ok. Close the project , then do the same and then get a serious error and GA4 does not work , the track inspector is greyed out . repeatable every time . I have tried uninsitalling both CP9 and GA4, hiding remaining files , but same thing happens . I have attached crash file.

When I uninstall GA4 , all seems to work fine .

Any pointers ?

cheers