9.0.10 Win: Fabfilter Q 2 crashes WL


starting playback with an opened instance of Fabfilter Q 2 crashes WaveLab.

Can you post which version of Pro-Q 2 you have installed and if you’re using VST 2 or VST3? FabFilter recently released a maintenance update as well as one bigger one in December.

Are you in linear phase mode (which level), zero latency, or natural phase mode?

I don’t get a crash here from simply Pro-Q 2 so it must be related to some deeper settings.

A crash report would also be useful.

VST2, no linear mode. I use the latest version.

So zero latency mode? Does the VST3 version also cause the crash in the same way? Perhaps a crash report for PG would be helpful.

Also important is where you have Pro-Q 2 inserted: in a montage on a clip/track/montage output or if it’s inserted in the global master section.

I remember something about a VST2 issue with some FabFilter plugins because of something MIDI related but I’d have to look back on the FabFilter forum about it.

If I insert a single Fabfilter Q 2 in zero latency mode as VST2 as a clip effect, WL crashes. VST3, however, seems to work.

Is there a reason you prefer the VST2 version over VST3? I’d have to dig through my emails or the FabFilter forum but I’m pretty sure this has something to do with either side chains or MIDI handling though I thought FabFilter was planning to fix it.

I think it would be very helpful if you can post a crash report.

Ok, I found the message from FabFilter about VST2 crashing in WaveLab. Here is the answer:

Hi Justin,

I’ve looked at the crash reports now. It turns out that this is a known bug in Wavelab. In short: our plug-ins with side-chain support expect valid references to side-chain input buffers, but wavelab doesn’t connect the side-chain when instantiating plug-ins in clips and passes invalid references… of course this crashes.

As a work-around, you can disable side-chain support for the VST plug-in via the plug-in preferences:

Mac OS X: Open Terminal and type:
defaults write com.fabfilter.. VST2_DefaultToNoSideChain 1
(For example: “com.fabfilter.Saturn.1”)

Windows: click the Start button type ‘regedit’ . Navigate to the HKEY_CURRENT_USER\Software\FabFilter<PLUGIN NAME><VERSION> branch. Right-click and create a new DWORD value. Name it “VST2_DefaultToNoSideChain” and set its value to 1.


Floris Klinkert
FabFilter Software Instruments

This should be fixed in WL.

FabFilter Pro-L is also not running.
VST2, inserted in the master bus, latest version.
Suppose it’s the same problem like with the FabFilter compressor

Try the VST3 version - runs fine here in WL9 Elements (Win 7/64).

Just tried it with VST3 - but the same issue, I see no difference.
Instantly app crash when inserting the plugin into the chain in the master bus, with FabFilter ProL and with DMG Limitless as well.

I have Pro-L in the 1.21 version and Limitless 1.02. All run fine so far. I cannot imagine there is a difference between WL9 Elements and the Pro version in handling plug ins.

The same issue for me:

Fabfilter plugins (among others) crash WL9.0.10…