9.0.30 graphics slowing after long session

Been on 9.0.10 until yesterday which was fine on the whole.

Skipped 9.0.20 as it audio glitched like an audio glitchy thing here all the time.

Now trying 9.0.30.

Seems to work well overall. The audio glitching seems to be cured.

BUT, had a 9 hour session today during which Cubase performed stably, but I noticed a slowing of the graphics performance through the day til eventually things like FabFilter ProQ2 were running at a slow enough frame rate to ruin the experience.

Closed Cubase and re-opened it with the same job. Did not reboot. Graphics back to smooth and full speed again.

So there is some time-dependent problem with graphics in 9.0.30 which needs to be fixed.

Overall though from my perspective, this is a pretty good release.


Similar situation here.
I wonder if we need to do some kind of system configuration to have a better experience with the new video engine.

I’ve just done a band session. 20 live tracks at a go, 10 different takes. No plugins - just audio.

As we added takes the session started to grind to a halt, until take 10 when it would take a couple of seconds to lasso some parts to select, or for dragged parts to register they had been clicked and were being dragged…!

Now, by take 10, we’ve recorded 200 individual files, but only 20 are playing back - same as after the first take.
It doesn’t matter if I’m showing all the takes, or I collapse the track to only show the playing track / comped part, this thing has become treacle - and this is a new Cubase phenomenon.

It’s now hard slow annoying work, but as I comp up my takes and delete redundant audio, the graphics start to work again!

What the heck is going on with this software?

Do you have automatic hitpoint detection ON ?

According to OP’s information, this seems to be a memory leakage issue unless OP could prove that the computer memory is not in full.
At least, something seems to be gradually out of what the application could handle.

This is just a guess, but I wonder if the memory leak is in the new video engine code.

I turned it off after seeing a post regarding the overall Mac graphics issue. I didn’t see any improvement then, but I still have it turned off.

Mh I recently mixed an album with about 750 tracks/groups/etc in the project - 25GB of Ram was in use, CPU was constant at Maximum in the end, UAD was at 98% etc… It took ages to open and because I had a tough deadline I was in fear about the “disappearing plugins” issue - so I let the computer on and Cubase open for about 3 days/nights… Had 18h working periods then a couple of hours sleep - I rendered countless exports for the clients to evaluate - till I exported the final mixdowns late at night after the project was open for these 3 days/nights and I applied HEAVY mixing in it, the undo history was most likely gigantic, i Imported countless track archives as well… I had no issues. No grafic slowdown.

More problematic is closing/opening projects - I make it a habit to close/reopen Cubase as well when I have to work with more than one projects - because it seems that closing projects often will not free up “everything”… I can not tell “what” - sometimes I have plugin errors when opening another project and stuff like that…

Thats why I still prefer (after 17 years in Nuendo/Cubase) to have one big project instead of lets say 10.

@Brandy: Just making sure, this was on 9.0.30?

mmmmmhhhhhh I am quite sure… but not 100%… I will check! When I open one of the project files Cubase will show the version…
I am just on another mix, I will check in a couple of hours!

ok ok ok ok… sorry, I was wrong… I just opened the original Projekt from 10. August 2:45 AM and it was saved in 9.0.20…

I mixed two other albums ins 9.0.30 after that and I had no issues yet, but usually I was running the session only for max 5-8h… So I can not tell if something has changed …

That confirms my suspicion that it’s a 9.0.30 issue only, possibly just the video engine.

For anyone having this problem: can you go to C:\Program Files\Steinberg\Cubase 9\Components\ and temporarily drag videoengine.dll to your desktop? This will disable the video engine. If the performance issue goes away, then we isolated the issue.

If we do not have Video in the projects everything will work like before?

No, only if you rename or remove the videoengine.dll

Regarding the “slow down”… It is an issue (for me) since lets say Cubase SX - during that Time I was using Nuendo2.

  • When you, for example, edit drums and you have quite A LOT edits/slices in a long song (maybe when using some kind of beat detective style editing) - then you easily will struggle with the problem that editing on these particular tracks will become more and more sluggish - in the beginning it is not a big deal - but when you continue, generate more snippets etc - it will become more and more impossible to move/cut events - after a while it will take one or 2 seconds till something happens…

Moving a good part of the song to fresh and empty tracks will fix it - this problem never was a “its a big project” thing - it was only a "there are too many events / pieces on ONE track… Project itself is fast.

It was NOT that way in Nuendo 1 (around 2000/2001) - then they made a complete new Audio-Eninge etc - I had it since Nuendo 2 up till now, in Cubase and Nuendo. I used about 5 or 6 DAWs during that time, from P4 over Athlon over Dual Opterons and since a while i7… SSD since years… Usually everyone will tell you “check your hard discs”… well, no - CPU at 3%, HDD almost no usage…

Maybe now this issue was boosted by the new video engine?

I’m pretty sure slowdown from many events is a separate (but real) issue.

OP here.

Slowdown of graphics is not a memory leak, well not unless it is a memory card graphics leak.

Throughout my 9 hour session I monitored system resources, including memory usage, and there was no leak, and plenty of free memory.

When people mention Video, are they referring to playing a video track in Cubase, or do they mean screen graphics? No video tracks for me here.

And I run a powerful graphics card onto 4 monitors.

I mean the new video engine. Even without added video tracks, it may be causing trouble in the background. By temporarily disabling it, you can find out if stops the slowdown from happening.

To disable the video engine: Press Windows+X, open Command Prompt (Admin). Copy/paste:

ren "%ProgramFiles%\Steinberg\Cubase 9"\Components\videoengine.dll videoengine.dll.bak

To restore the video engine: copy/paste:

ren "%ProgramFiles%\Steinberg\Cubase 9"\Components\videoengine.dll.bak videoengine.dll

I renamed manually - with some other dlls which I do not need (hub etc) - no issues so far. I barely work with video - if I do I can rename at any time again :slight_smile:

OK Thanks for that tip. I will note it for the future.

However, before I even tried your trick, I did more long tests. Two sessions of 8 hours and no graphics slowdowns any more.

So at this point my problems have gone away - fingers crossed.