Tried updating my 9.5.41. It only updates Sonic SE. It says the content updater is already installed and that Cubase 9.5 is not installed, even though I was just running it.
Checked my usb licenser - no problem there. Re-started the computer and got the same results. Anyone else get this?


Is your Cubase installed on the system © drive?

I just copied the program from my desktop to a new laptop I got. I guess I’m going to have to download the actual installer program.
Cubase 9.5 isn’t listed in ‘programs and features’ even though it runs fine. And yes, it’s on my C drive.
So, I guess I’ll call it ‘solved’ for now, even though I haven’t had chance to do it yet.


You cannot just copy it. The files are really installed (you are not on Mac). :wink:

You have to make proper installation from the Full Installer.

Yes - I’ve learned that now. I downloaded, installed, and updated, and everything is fine now.
Funny part is though, when I just copied it, there were no major problems that I ran into, other than it wouldn’t do the update.
The dongle recognized it, Halion too, and it seemed like all was good. Oh well - it’s fixed now.