9.5 Not use Direct Offline Editing

Having a problem with the new Direct Offline Editing.

I have a pile of macros that worked with iZotope RX 6.

EG: Select range of an event
Macro opens De-Click
Press process
Plugin processes, window closes, track pre-rolls and goes into play.

Now on 9.5 the same macro opens the Direct Offline Processing instead, applies and then rewinds and goes into play.

The problem is, the plugin is still loading, and it jumps all over the place and doesn’t even get as far as applying properly!

For editing voices for audiobooks, which I am currently doing, the old method was WAY better and much faster. I think I am going to have to mess with the macros to take the pre-roll and auto play bit off, which slows the whole thing down.

Can make it work the old way with destructive editing?

Also, since this is non destructive, is there going to be a problem with the number of edits? In a 1 hour long chapter, there can be 300 edits plus a ton of de-plosive, de-click, de-crackle and so on.

Direct Offline Processing completely replaces the old Offline Processing system. I haven’t tried using it with macros yet, but some changes to your current macros and/or workflow may be required to take full advantage of it.

These pages explain how it works:
https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/direct_offline_processing/direct_offline_processing_c.html

Basically, the original file is left untouched. Every time you make a change a new file is rendered offline, so only a tiny amount of RAM and no CPU is used when you apply offline processing. I would be careful with it if your hard disk is very close to full though.

This system is much more flexible than the old one, and you can get really surgical with it. You can now easily undo offline processing at any point during mixing, and these processes can be undone in any order. You can experiment with as much processing as you want without having to worry about being unable to go back later on, and you don’t have to worry about applying processes in the right order.

Thanks, Romantique.

Yes, I do like the idea of it, but it is a little clunky on the GUI front. The useful thing about the old system is that it waited for me to hit the Process button on the RX plugin. Then it would run the rest of the Macro. This just goes for it all in one go, not allowing the plugin to get started properly or for me to adjust the settings first. iZotope RX 6 is brilliant repair and restoration plugins, but hardly lightweight. They take just that extra couple of seconds to load.

I just installed Trial 9,5 and found DOE useless. I also often use RX6 and- with the new 9,5, it doesn’t work at all. DOE should be an OPTION, not REPLACEMENT of old important functions of Audio Editor.

It works alright with RX plugins, just not with my macros. It helps if you don’t have auto apply on sometimes. I am sure there is a way of programming this up with macros better, but I haven’t worked it out yet. Pain.

https://helpcenter.steinberg.de/hc/en-us/articles/115000946570-Nuendo-8-Direct-Offline-Processing-iZotope-RX-Connect-

I had big problems with DOP crashing DMG and Auto-tune amongst others, but when i reset the graphics card settings to default and updated Windows 10 (Fall creators update) all is good :slight_smile:
Not sure what did the trick, but it works now.

That is for using RX connect. For most operations, you just need to use the RX VST3 plugins direct in Cubase/Nuendo just as with any other plugin.

The connect comes into play when you are using certain modules or module chains in RX 6 that cannot be accessed as a simple plugin.

Timo (from the Nuendo team) mentioned that better Izotope RX integration will be coming in the future. Maybe that could include a fix to this issue.

Outside of this issue I think that DOP is just plain superior compared to the old system. It gives you a degree of freedom that I’m sure you’ll grow to appreciate once this gets sorted out.

How long does this RX module take to load for you? I don’t have RX here to test this, but maybe adding dummy commands such as opening and closing some window (same command over and over) could work to give the plugin enough time to load.

Not sure, Ramantique. It doesn’t take long, but it does seem very cumbersome.

I have been digging through commands, but cant find what I need. The old way it worked, I had a macro that:

Opened the plugin (whatever plugin)
Locate to front of selection
Used Pre-roll
Went into Play
Used Pre-roll again (this effectively turned preroll back off)

Once the plugin loaded, it interrupted the macro. Once I pressed Process on the RX plugin, the rest of the macro ran. Very neat.

With the new system, it seems to be trying to do everything at once, so it rewinds and goes into play before the plugin has actually processed anything.

I need to mess some more and find a quiet moment to think it through. I get the impression that it has been created to work with the very typical selection of plugins, and does not take into account more complicatd plugins that have to work harder, or for production people like me who work at high speed and want short cuts for everything.

I even have a modified games keyboard which has my most common macros plug a couple of transport bits, undo, save, etc, programmed as single keys. For most voice editing, I use that and my mouse - very fast!