A# Bb wrong event display settings or?

  1. Put midi or instrument track and make event.
  2. Write note on A# (its showing as Bb)
  3. Go to the Preferences/Event Display/Chords&Pitches.
  4. Now settings "Display ‘Bb’ as 'B’
    This setting doesent make sense or I am doing something wrong here.

Lets say I want to see A# on piano roll instead Bb as it was before. How?

It’s caused by a new feature in C9 wherein flats are shown in the Key Editor according to the current chord on the chord track. You won’t see A# unless you activate a chord track and insert a chord whose scale contains A#.

It appears that Bb is the only note that is flatted by default.

The setting you mentioned does work here, but is for respelling Bb and B to the German B and H.

It will have more sense to see Bb only when you enable chord track with particular chord, and A# to remain as it was through 15+ years how I work with Cubase.

I certainly do not disagree with you. It appears only Bb has this different behavior, so maybe it is a bug. (but nothing to do with Bb=B and B=H pref)

Its corrected in 9.0.10 update :slight_smile:

Not so fast. By chance I posted an issue report on this yesterday & was happy to see it was supposedly resolved today.
https://www.steinberg.net/forums/viewtopic.php?f=254&t=111866

However my test Project, now saved as 9.0.10, shows the problem still exists. I did an update in the issues forum and am waiting its approval. But in my OP there I posted this screenshot of the problem and it looks exactly the same in 9.0.10.
https://www.steinberg.net/forums/download/file.php?id=19750