a strange behaviour of rhythms


When opening a saved document, two tied crotchets (two tied quarter notes) in a specific bar are converted to a minim note (a half note).

The triangle part before saving the dorico file:
Screenshot 2019-02-09 15.01.00.png
The triangle part after opening the dorico file:
Screenshot 2019-02-09 15.09.05.png
Is this a bug or is this intended?

There’s a setting in Notation Options under Note Grouping which takes care of this. The section is called ‘Notes starting after the start of the bar of multiple beats in duration:’. If that doesn’t change this behaviour, perhaps the note has been entered using force duration. In that case, you should change the defaults in the above Notation Options the way you want them and then select the note and select Reset Appearance under the Edit menu.

Also check on the option controlling notes that cross the half bar. Force duration is always an option if defaults don’t get what you want; force duration will never be overridden by auto settings.