Abnormally High Performance Load

Hi all.

I’m running the latest version of Artist 7.5 on an 8-core Mac Pro (2 x 2.8 Xeon Quads) with 32gb of RAM and the performance load seems ridiculously high.

I’m new to Macs having just moved from an i7 PC so perhaps it’s a simple setting.

For example I’m running 7 audio tracks and 3 instrument tracks at the moment with an average of 3 plugins on each and my average load is tickling the red, on my old PC with Cubase 5 that wouldn’t even be touching the sides.

This surely can’t be right, is it?

I’ve been through every plugin and while some are obviously hungrier than others there’s no single plugin or instrument causing a huge overload.

I’ve tried 64 and 32bit modes, disabling/enabling ASIO guard and multi processing, updated my soundcard driver (NI Komplete Audio 6), tried disabling my soundcard and using the internal sound. Soundcard is set to 512 samples with 13ms latency, even dropping to 2048 samples only reduces the load slightly.

Can anyone help?

Full spec and details:
8 Core Apple Mac Pro Desktop
Late 2008 Model A1186 EMC 2180
2 x 2.8GHz Quad Core Xeon CPU’s
32Gb RAM
1 x 250Gb Crucial SSD
1 x 1Tb SATA HDD
2 x NVIDIA GeForce GT 120 512Mb GDDR3 Graphics Cards
2 x Superdrives
OS X Mavericks 10.9.4
Cubase Artist 7.5.3
NI Komplete Audio 6

No, it is not right, it should be better.

  • Is this the same if you hide the prefs from Cubase to initialise a new set?

  • You should leave Mutilprocessing on in any case.

  • Have you troubleshooted as follows?
    Add one track at a time and watch the average load as you add them. Maybe you’ll find something.

Other folks might have other troubleshooting ideas, also it might be a good idea to open a ticket at SB support.

(I moved this to the General subforum, Issue Reports is not for trouble shooting, it’s more for reporting bugs.)

First off, thanks for taking the time to reply and keeping me in the right sub.

Not tried hiding the prefs but this was a brand new install of 7.5 on a brand new clean install of OSX so there shouldn’t be any old pref issues I wouldn’t think? If you think that might be an issue then I’ll give it a bash.

There were a few older plugins that I use a lot that I hadn’t noticed were using Bridge so I was hopeful that’d solve the issue but sadly not.

It seems to not like 3rd party plugins too much;
I can run 32 channels of Retrologue with 8 Steinberg effects on each no problem although processor still running higher than I’d expect. https://www.dropbox.com/s/gk6xcl2ovsr74yv/Screenshot%202014-09-07%2023.29.45.png?dl=0

But run 16 channels, even of the initial preset on Massive with 8 plugs, none of which are CPU intensive and it’s hitting the skids. https://www.dropbox.com/s/2g255475n22nm6b/Screenshot%202014-09-07%2023.37.54.png?dl=0

I see what you’re saying. Well, it’s super easy to rebuild the prefs, though I don’t have high hopes that this is the problem.

  • Quit Cubase
  • Do shift-command-G in the Finder and paste in:

~/Library/Preferences/


* Find the folder "Cubase 7.5" and change its name to anything. I do Cubase 7.5x
* Launch Cubase.

Nope, that didn’t help :frowning:

I’m sad to say, that this old Mac pro isn’t much bang for the buck.
Most likely your “old” i7 PC is a lot faster.

It is also possible that it is clocking itself down because of heat. The 2008 range of Mac Pro have problems with excessive dust. You should open it and use a lot of compresses air to blow it clean.

Do you see any better performance when using the built-in soundcard?

P

No, in built sound card is just the same. Clean as a whistle inside, was a refurbished model.

I just checked in Ableton and I can run 16 channels of a CPU heavy preset on Massive with 7 hard working analog modelling plugins on each and the CPU meter is only at 49%.

So seems to be a Cubase issue…