About Record To Audio

Hello, I have two questions if anyone could help me that would be great thanks :smiley:

  1. How do you record a melody with release or delay that Extend beyond the time like 1-5 bar Or other time
    Because when you hear it in the midi all sound good and the loop prefect but when you record to audio you need to
    Extend the locetur to like the 1-6 bar and then record But then it does not in loop so what need to do in These situations ?

Like this img

2. When I record synt midi to audio I find that the nute not sit tight to the bar or bit like in the midi and some nute in the melody are come late and some come early there some nute late like 80 sample and some 120 ,40 and so on…
Soo what can be down to slove this ?
"Because there are nute that you can not just move them that is difficult to determine and see where to cut the nute
especially if have release or nute start right after nute and so on "

Like this



  1. Turn off looping before recording, then it’ll record the tail. You’re probably doing that already… (I’d also recommend that you don’t start your audio at time zero, move it a few bars to the right so you can have a run-up. Historically this has caused problems in the past with playing accurately at the start of your audio).

  2. I thought this was normal behaviour for VSTi’s in that they’re not always in time. I tested this once and that’s how it is on my system at least. The size of ‘jitter’ was related to my soundcard latency setting, the smaller the better. Maybe it depends on device drivers too?


Thank you so much I’m actually recording like you said but I ask after i recording what to do with the tail Because of the sound then is long more then the Loop and if i need to Duplicate it not can be … the option that i see is to just open Another channel And put there the duplicate or to cut the tail and put t in outer channel and do some fade like in the picture

Channel on channel image:


Cut the tail and put on the start


I’m actually wondering if anyone else does this or is there another way ?

And about the jitter its not from vst its from external synt to audio but even from just midi to midi its happen
The vst instrument time are great

  1. Yep, that’s what I’d do. Because you can’t have two audio events overlapping on the same track. You could use a cross-fade tho but it’s best and easiest to use 2 tracks.

  2. External synths, for me, the same sort of thing, I measured that as well once! Due to latency in the midi transmission out of the DAW and probably also the keyboard being able to respond to create audio. You could reduce the delay by moving the midi forward a bit using the track inspector Delay setting. That should help the overall delay, but not the jitter. You’d need to move each sound by eye. (there may be a preference for midi recording but I’ve not delved into this area for a long while).


Hahaha… Yes i know track delay i use it but the jitter is the :imp:
I try to fix thing by Eyes but it wont work for me if there have a sound with high release or nuts after nuts its difficult to see were to cut

You could try another midi unit. I’ve noticed different performance out of different units. For example, my main unit is the Midex8 and it’s supposed to have some tight timing driver specially developed by Steinberg…

Also have you tried to reduce your sound card latency to see if that helps?