Accidental inconsistency

How come the accidental is displayed inconsistently?

Dorico_accidental.dorico (541.2 KB)

Is there a setting to correct this?

Notation Options—Accidentals.

It does not explain why one bar has ( ) and the other does not, depending on the previous duration.

Edit: Seems to be a MIDI or XML import problem. Selecting the last top note and resetting the appearance shows the ( ). Hm. Is there a way to select all notes with accidentals as I don’t want to reset the forced duration?

You could select all notes, toggle on the accidental visibility, then toggle it back off, and in theory everything will go back to its default state.

Also, as a general rule, you should always select all and reset position and reset appearance first thing after an xml inport. That way Dorico knows it’s ok to handle everything as it sees fit, rather than trying to honor whatever weirdness may be baked into the xml file.

1 Like

Yes, I always do this, but sometimes, due to too many errors in XML, I have to re-enter a bar, and possibly then some error was added that caused this. I can filter sharps and flats, but naturals are not on the list.

An interesting ‘trick’. Thanks, I will try this.

It shouldn’t matter if you are just toggling accidental visibility. Am every accidental is covered in that case.

Selecting all, or a smaller part, makes the properties window (mainly) empty. This trick did not work, but it was a good idea.

Select all the notes. In other words, select all, and filter for notes only, then the proper options will be visible to you.

1 Like

Aha. Many thanks!

1 Like