Accidentals collisions in Dorico 5

First ever time this happens to me on Dorico: colliding accidentals!

Is it normal?
My note spacing settings are unchanged and I never ever had this problem with Dorico!

We really need to see the whole system, at least! What’s the spacing percentage in Engrave mode?

1 Like

I see that there is something happening when the notes (and accidentals) are outside the staff. Spacing is good if accidentals are within the staff, if not they appear to be above the rests…
I’ll post the entire system in a bit. But for info it’s still rather empty, it’s still being written. There’s not much on the page, so I doubt that it’s because of the staff/system/frame percentages.
What spacing percentage do you mean in engrave mode?

I was wondering if the system was overfull:


If that’s not the case, then perhaps some Engraving Options are not what they should be.

Aaah that percentage!! I was looking for something in the engraving options and didn’t even think about the editing panels.

Yes, it’s actually 94.1% right now… Which is indeed high!
I’ll look for that setting again if it doesn’t change when I start filling up systems and pages.

But I notice the same behaviour when switching to “galley view”, which is also kind of odd.

It’s not that high. It means that the current Note Spacing value spaces the music to just a bit less than the width of the system. So it should not be a problem.

However, the more we can see (which will include the project file (or a cut-down version); the better.

Starting a default piano project;

The bar is not stretched to fix the collision.

As @zenoor-13 writes, once close to the rest things are normal;

As soon as the accidental interfere with the rests it adjust correctly;

Seems like D only looks back on the previous object;

It can get rather ‘strange’;


Yes, as Daniel mentioned recently, Dorico does collision avoidance only for beat-adjacent items, so the intervening rest prevents proper spacing. Fortunately if you’re <95% full there is plenty of space to fix it manually without having to lock system breaks.

1 Like

BTW, is there a setting for turning off accidentals ‘hanging’ over rests?

1 Like

What if you put in a quaver in another voice and hide it and suppress playback? Would Dorico take account of that for spacing in this case?

Certainly you can adjust it manually, but the whole deal is that it should be better handled automatically.
In no case I can imagine this is convenient as a default behaviour, and in a score with a lot of accidentals it is not really practical to have to check and adjust everything manually… Especially knowing that in most cases Dorico is pretty good at dealing with automatic spacing (it’s one of the reasons that made me switch from Sibelius to D 3.5 years ago).

Couldn’t find one. But definitely is something I’d like to have!!

I think in general such an option would make the spacing considerably worse rather than better, and we don’t plan to introduce one.

If you’ve read my reply in the thread that Mark linked to, you’ll know that this is something we plan to address in a future version, but I can’t say for sure when it will happen.

1 Like

I think it is Daniel’s intention to have Dorico avoid situations like the 2nd;

where the LH gets ‘uneven’.

However, a property such as “Never let accidental(s) hang over the previous item” in the Accidental section could be useful in some situations. Adjusting in Engrave mode does work, but it is still “flexible padding” so it might, after adding more music to a system, need further adjustments.

As for the example above I cannot decide for myself what I like best, prob. something in the middle of the two samples;

But still, neither is optimal IMO. It is a ‘tricky case’. However, there will always be cases where you get an ‘uneven LH’;

(and here I’m more ‘bothered’ by the closeness of the # to the (…)

I’m not sure it is “allowed” to have the notehead for the Abb to be placed over the rest, thus at least

Are there some “Henle samples” of how this was dealt with “in olden days”?