accidentals modernist options

Hello Daniel

I’m trying to use the changes added in the accidentals modernist options.
I’m having a hard time getting what I need which is :

-naturals cancel within a bar as in standard practice
-accidentals always restate within a bar “except” in the case of successive repetition(s)

For now, I can’t find the setting to get there.
Also, I get incorrect results using “Persist to the end of the bar” with “always restate” settings.

Best
Yan

I’m sorry to insist but there seems to be something wrong here with the modernist options…
I’m monitoring the notationOptions.xml after applying Save as Default in order to check the effect of the options and they are not working as expected.

Please, could you give it a try ?
Best

Yan

bool: true bool: false bool: false bool: false ![settings result.jpg|685x71](upload://urc9g5I75wyqssMU4YRjEOHYO0U.jpeg) ![settings.jpg|649x953](upload://8hK7yezgVolXjZRtlidX5dbIA9d.jpeg) ![viennese result.jpg|722x65](upload://fXpUj2RbCyZb9YuAHeAzhYsdTiG.jpeg)

Yan, please be patient, and don’t bump threads. I will come back to you as soon as I have had time to look into your issue in detail. You might have noticed that it’s been quite a busy day today with quite a lot of things going on!

I’m sorry to bump this thread again but I never received any answer and it has been 15 days now.
I just need to make sure somebody can repro my issue and/or acknowledge that there is a problem with the various options added to accidentals rules with 3.1

These settings work well for me if written down in the xml file, mut they make no sense in the GUI…
bool: false
bool: true
bool: false
bool: true

Thank you

Best
Yan

I’m sorry that I’ve not yet managed to respond, but I can assure you that I have not forgotten about this and will look into it as soon as I can find the time. I hope you can appreciate that there are thousands of users and only a handful of us on the team. In the immediate aftermath of a release we are even busier than usual because of the higher level of interest and discussion that naturally follows. Please be patient, and don’t bump threads.

I tried the same settings as you and get the same results. However the combination of “-accidentals always restate within a bar “except” in the case of successive repetition(s)” together with cancelling naturals in the ordinary way is not one which appears to be possible within the options offered so you seem to be right here until a team member begs to differ. On the other hand, why do you want this, to my mind, rather strange combination? If you could justify it --perhaps other composers use it? – then I’m sure some advice would come your way.