accidentals question


I’m editing music from a midi file import and I have to change many notes to their en harmonic equivalent, and / or change and edit some music to fix some quantization issues or else.
In some frequent cases, after edits, some subsequent notes from the edit do not show the proper accidentals like a natural needed for cancellation of a new note with an alteration for example.
I often find myself in doubt, and I need to go to properties/accidentals to “show” and check. In many case, I then have to add that accidental.
I see that if I use the Second Viennese school option things are displayed right.
I use the modernist option for accidentals, so I’m wondering why some accidentals are not showing.
Is it because it is originally from a midi import or something else ?

A: there is a D natural on the bottom of the chord
B: I pasted the fist two beats from another bar, the D in the chord does not show the natural accidental automatically


Within the Modernist options, do you have the following option correctly set?

It’s also possible (though unlikely) that the notes have explicit properties set for accidentals: try selecting them and doing Edit > Reset Appearance, which will remove any overrides set for accidental appearance.

Thank you Daniel
Yes my options were set correctly.

How would explicit properties be set ? Can an musicxml import be the cause of this ?

I have other odd cases like the following (see picture) :

The A note in the first chord on measure 18 is an A natural, and despite the option and reset appearance, the natural does not show.
When I check with Accidental property, the A natural signpost shows but the the setting is on Hide.


Preferences > Musicxml Import > Accidental Visibility can absolutely be the cause of this, IF this is an importer MusicXML file.

Oh I really don’t get it…
All my option are set right, none of the notes have explicit properties accidentals anymore and I still find accidental issues in this document.
What can I do. Do we have a side way to check accidentals ?


Yeah, but how were the Preferences > MusicXML import options set when you imported the file? They’re not retrospective.

If memory serves me correctly, there are properties in MusicXML files that don’t appear properly in the properties panel, because they exist in a different scope: they apply to the object in all layouts, whereas Dorico’s properties are Layout-specific.

If the import settings weren’t set correctly when you imported the file, and you’re in this mess now despite having Reset Appearance, the quickest way out may be to reimport the MusicXML file with the correct settings.

By the way, your OP said it was a MIDI import. What kind of file was this originally?

Oh… I am to far ahead now to reimport.
Tons of edits in there…
I don’t remember if it was midi or music xml, (may have been xml) but due do the enormous trouble I have to keep track and fix all the accidental issues, it must have been for sure imported from a file with the wrong options.
I have to take care of cancellations all by hand :frowning:((
We need a accidental fixer of some kind, even if wrongly imported !



Let me make sure I understand correctly what you are saying here.

I have this bar :
Screenshot 2019-10-05 at 14.46.00.jpg
I change the E# in the last beat for F natural using “Respell using note name above”
I get an F but Dorico does not put the natural for me (cancelling the previous E#)

Are you saying this is normal because I imported this in xml some time ago with the wrong settings ?
There is nothing I can do to fix this in this score unless I start form scratch again ?


That’s precisely what I’m saying. If you’re determined to continue with the file as it is, then note that you can assign a keyboard shortcut to “Toggle Accidental Visibility”. You’ll need to be vigilant but at least you won’t need to keep reaching for the properties panel.


If we look at the effect of the 3 main options for accidentals, the only one giving the problem I’m experiencing is the Modernist…
Notice how the E in the 3rd beat is rightfully stated as natural except in the modernist version.
Common Practice.jpg
Second Viennese School.jpg
I checked and checked again my settings :

int: 2 bool: true bool: false bool: false int: 1 int: 1 int: 1 int: 1 int: 1 int: 0 int: 1 int: 1 int: 1 int: 1 int: 1 bool: false bool: false bool: false bool: false bool: false bool: false bool: false bool: false bool: false bool: false bool: true

This is horrible news…
I don’t understand how come it’s not possible to fix this automatically.
Two of the three accidentals notation options can fix this.



Am I misunderstanding the modernist option ???
I also expect accidentals cancellation on non adjacent notes if they are in the same bar, or on the beginning of the next bar…

From reading carefully all the options, I have a doubt now.
Also, by entering a few notes with my keyboard, I don’t see any accidental cancellation on non adjacent notes…

Yan Maresz

Yan, which specific modernist options are set to what?

I tried different options in a new file. No solution for me here.

What I need is Second Viennese School but with the possibility not to show naturals unless needed.
Modernist, but with traditional natural cancellations if needed within a bar


What is really odd is that in the modernist options, there is one that does not make much sense to me.
Screenshot 2019-10-05 at 18.04.42.jpg

  • When using “always restate” you don’t have the naturals cancelling the alteration,
  • but if you don’t restate, then you do.
    I would need always restate WITH the naturals

Look at the text, not the picture. I suspect the pictures are wrong.

Hallo, Yan,

I also ran into some limitations re: the accidental rules; while the team has taken care to implement historical criteria that cater to yesteryear’s music, it’s not exactly straightforward to yield criteria that serve contemporary needs (such as, for example, Durand’s current accidental rules). Seeing as you can filter by sharp and flat notes, what I have done was selected all, filtered sharp notes, set their Accidental visibility property to show, and repeat the same procedure with flat notes. This will, in principle and coupled with the Modernist setting, yield you something closer to what you might want.

Oh thanks LSalguerio
Thanks a great workaround…

You are right. I publish my music at Durand hence these house rules for accidentals…

Daniel, I beg you; many Universal composers (Durand/Eschig/Salabert, Ricordi, we are talking about at least a 100 published composers here…) will need to be able to have what in the end is the ability, in common practice to allow repeated alterations within the bar. To have to do this by hand is just not right.
I’m trying to bring Dorico into the house, but as it is now, it is going to be a problem for many of their copyists.
I hope you will hear me on this one.

Thanks !
All the best