Activating Listen on Selected Channel

I know this has been an issue… but I don’t know where it currently stands. This is the only remaining thing that prevents me from moving full bore into Cubase 7.

Is there a way, under Cubase 7.03 to set up a key command to activate listen on the selected channel?

It seems they have a key command to listen enable ALL VISIBLE channels, but… I honestly can not imagine what use that would be? Or if it is, why they would have that, and not the ability to activate it on the slected channel as well. I could create a macro that makes the selected channel visible, and then activates listen, but there’s no way to restore the previous visibility state (whatever it might be) within the macro. ::sigh::

Anyway, can anyone help me here? I’m not one to complain–I know it will take time to get Cubase 7 up to full speed, but I can do this in Cubase 6.5 easily… as that key command exists in Cubase 6.5. It doesn’t seem to be there in 7.03. Without this ability, I’m still going to be needing to do most of my work in 6.5.

Mostly I just need to make sure I’m not missing something obvious…

Okay I found a workaround. It’s not great, but it’ll do.

Again… unless I’m missing something, this is what I have to do:

Set up a macro with the following commands:

1.) Mixer - Agents: Show only selected channles
2.) Mixer - Listen for all visible channels on/off
3.) Mixer - Agents: Undo Visibility Change

That last command (“Undo visibility change”) was not available as a key command in 7.02. It is in 7.03, which makes this workaround possible.

Anyway, this will work, but it has its own problems. Steinberg, please bring back the “Activate Listen on Selected channel(s)” key command, and please make sure it works regardless of whehter the mixconsole is in focus or not.

If someone knows something I don’t about this, by all means, tell me if I’m doing something wrong. :slight_smile:

Thanks everyone.

Key commands -> Edit -> Listen

A Listen button also strangely seems missing from the CMC-CH Controller!

Yeah, there is no Enable Listen for Selected Channels. As an alternative your macro could use Link Channels and Unlink Channels, if you prefer a different set of problems. :wink:

Thanks, all, for the confirmation. :slight_smile:

Hm… I’m not sure what this command is SUPPOSED to do, but it doesn’t do what I need it to do. :slight_smile: What’s strange is that there seems to be two… levels of selecting a channel in the mixer. One is when the channel turns a light grey color. That, as I understand it, is a “selected” channel–at least that’s how it was in Cubase 6.5. But there is also a different kind of selection where the channel gets outlined by a thin red line. I don’t know what that is exactly, but the two are not the same thing. When I switch channels with my CMC-CH controller for example, it will move the highlighted light grey indication to whichever channel the CMC controller is controlling–just as it did in Cubase 6.5–and that is, I believe, the “selected” channel. However, the red outline will stay where-ever it was.

My point is that the “Edit --> Listen” key command seems to only effect the red outlined channel, and not the grey highlighted, or selected channel. So moving through channels with the CMC controller and trying to use that command to listen enable whatever the CMC controller is controlling does not work. So… back to my macro I go.

Can anyone explain to me what is going on with that red outline and how it is different from the selected or grey-highlighted channel? Pehaps I need to look at updating my Tools for CMC–maybe that will solve that particular problem?

And yes… if only the CMC-CH controller had a listen button. ::wistful sigh::

The grey highlighting is as you say, channel selection. The red outlines are to indicate focus of the individual sections and operators. This is a feature of the keyboard-navigation control and is described in more detail on PG. 183 (Eng) of the Operating Manual.