Activation Manager won't even starts!

I’ve succeeded in activating cubase 12. At pc first boot it startes , activation manager founds the licence and works but if i close Cubase and restart it says “licence not found”; Then I try to open the activation manager but i doesn’t start at all.

Any suggestions?

Hi @muttleysat73 - welcome back to the forums! Sorry to hear you’re experiencing issues.

Is it the same each time that it only works after rebooting? Which operating system are you using?

Hi Ben

I’m using Windows 11.
When I boot I succeed opening the activation manager and cubase works. When I close Cubase and try to reopen it says License missing , and that’s because activation manager won’t open at all

More over, even if Cubase 12 is activated, when I try to kno the eligibility period it stucks for minutes and then it say “I cannot find any license”

Would you be able to ZIP up the files in %APPDATA%\Steinberg\Activation Manager\Logs and send it via PM to me?

If Steinberg Activation Manager is showing you have an active license for Cubase 12 then you shouldn’t need to run the grace period check again.

I think I’ve found the problem but not the solution.
I’ve tried to restart Cubase 12 several times and it works , even if it displyas that the new content sonftware is not authorized.
If I run the e-licenser and do the maintenance (which is impossible to accomplish until now) than Cubase won’t start and the activation manager won’t open.
Is this problem due to Steinberg Servers?
I’ve got Steinberg Conncet which is still on my usb dongle. How can I move the license to activation manager?

If you have a working active license for Cubase 12, I wouldn’t worry too much about opening eLicenser Control Center.

Not all product lines have made the transition to Steinberg Licensing yet, so you might have to hold onto your USB eLicenser for a bit longer.

If you are still having issues with updating to Cubase 12, please let us know here: Updating to Cubase 12 – STATUS UPDATE – Monday, March 7th - #2