Activation problem


I’m new on this forum, so please excuse me for some beginners mistakes…
A few years ago I bought Cubase 5. Because of several reasons I didn’t get to install it/work with it quick.
Today I finally unpacked the box, installed the program and the USB-dongle for the activation. All went fine.
Only when I started the special program to do the activation with, I ran into a problem.
The activation key (from the form) was entered fine, but after clicking on START for the actual online activation to begin, a dialog box with a red cross appeared, telling me the online connection with the activation server could not be established and that I should check my internet connection. This kept happening all the time so the activation could not proceed. My internet connection is fine, really. I was able to go online with Google Chrome all the time.
So I wonder what can be wrong. Maybe the server changed?
Any help would be much appreciated!

Thanks, Marathanz

If you haven’t yet, install the latest eLCC from here …

Hi Scab!

Thanks for your quick reply. That does make a lot of sense of course!
Because, no, I didn’t yet update the licenser software…
I’m gonna give it a try!


Hi Scab,

The activation went fine after updating the elicenser software.
Thank you for your help.


You’re welcome.


Hi I’ve got the same problem but updating elicenser software didn’t help. The same window with red cross appear. What should I do ?

please tell me why i keep getting this

I can’t read it. Tried zooming in but it is too blurry and grainy.
More information would be helpful.