Addictive Keys instances not found

Hi everyone,

I’m experiencing a rather strange issue. I’m not entirely sure if this is a Cubase or an XLN problem but this is what’s happening:
I’m just setting up Cubase 12.0.40 on my new Mac mini (M1) after switching from Windows 10. Currently running in Rosetta mode due to NI plugins not being M1 native yet. So far, everything seems to work wonderfully, except this:
I tried opening an orchestral template project I created on my Windows PC and all my VSTs open just fine except for an instance of Addictive Keys, which is “not found”. AK does show up in the plugin list though, which is rather odd. I had a look and realised that despite both VST2 and VST3 versions being installed, Cubase treats them as the same (presumably because they share the same ID) which means I cannot use them in parallel. Oddly though, Cubase defaults to only showing the VST2 versions if both are installed. So I uninstalled the VST2 version, thinking that maybe I used a VST3 version when creating the template and this is where the issue lies. Now the VST3 shows up in the plugin manager as expected, but the instance in the project is still not found.

tl;r Cubase doesn’t recognise existing instances of Addictive Keys regardless of which VST version is installed, but AK shows up in the list and Cubase has no issues creating new ones.

If anyone more knowledgable than me has got any clue what might be going on, I’d appreciate it greatly.
Thanks everyone.