Adding Ensemble didn't work properly


I had written the string part of my composition that I decided to add a woodwind ensemble to it. I selected “add ensemble” and added double woodwind as in the image below:
Screen Shot 2021-01-05 at 11.02.23 PM
The setup showed correct players.

However, after I played back I noticed that my first violins staff are played with Oboes! Also there are no Flutes I and II in the HSSE!

I can fix it in HSSO. I wanted to bring the developers’ attention to this error!

To reproduce: start by a single HSSE

slot 1 -2 : Violins I combie A and B both with assigned midi input channel: 1
slot 3 -4 : Violins II combie A and B both with midi input channel: 2
slot 5-6 : Violas I combie A and B both with midi input channel: 3
slot 7 -8 : Celli I combie A and B both with midi input channel: 4
slot 9: Double basses Combi with midi input channel: 5
Now add the double woodwind ensemble.

I’m not sure there’s anything to bring to the developers’ attention.

By the looks of things, you’ve added some instruments, then manually adjusted a load of stuff inside HSO, then added some more instruments.

If you don’t touch the VST until you’ve finished adding instruments (and I’m going to go as far as to say that a majority of users never manually adjust the VST) Dorico will happily assign correct playback instruments on your behalf.

If you rejig stuff inside HSO, then add more players, you’re going to run into trouble unless you manually assign percussion maps and expression maps to endpoints.
Start by reading this page of the manual.


This is a great feature and it was a great read!
I need to make my own playback templates.
I just said to make the Playback template more robust in the future.

The Playback Templates are robust. They’re like Master Pages overrides, though, in that as soon as you manually fiddle you need to resign yourself to future processes also being manual.

1 Like

Well. I removed the VSTi and added two fresh HSSE VSTis one for woodwinds ( doubled each instrument) and strings ( manually doubled A and B combis). For the woodwinds, it worked.

However, the strings show up like this.

So to add the ensemble in my score with proper expression maps, etc., Do I need to duplicate the “HALion Sonic SE” and create a new end.conf with my desired setting for custom strings-doubled ensemble?

PS. According to software engineering practices:

Robust Definition . The word robust , when used with regard to computer software , refers to an operating system or other program that performs well not only under ordinary conditions but also under unusual conditions that stress its designers’ assumptions.

Have you understood that you don’t need to manually add VST instances when you add players to a Dorico project? If you want Dorico to handle this automatically, go Play > Playback template and reapply the playback template.

well, I saved it as a new version of my project. Then went to Play > Playback template and reapplied the playback template.

Now my VSTi 1 and VSTi 2 are combined into one, VST2 is removed and Strings are not Combi A & B doubled as I desired.

Screen Shot 2021-01-06 at 9.56.39 AM

If I want to have my strings doubled, HSSE doesn’t have enough slots for woodwinds and strings (8+9 = 17). Now sure how to go about this case.

Thank you for the help!

Yes, HALion can handle 16 tracks per instance so you’d need to split them across multiple instances if you need 17.

To the best of my knowledge (emphasis because it’s not my area of expertise), Dorico can’t automatically route the same track to multiple MIDI channels.
HALion can, of course, but endpoint configurations are (as I understand it) a one-to-one relationship.

Hopefully someone will set me straight if I’ve got this wrong.

It strikes me that you seem to be going rather an odd way around achieving a pretty normal result. Your string players are solo players, which means that by default Dorico’s routing them to the HSO Solo instruments rather than the HSO Combi instruments. If you want HALion to use Combi instruments, because you want your strings to sound like an orchestral section rather than a string quintet, move your string instruments (in Setup mode) to Section players.