Adding Instruments Issue

Issue 1 - Adding Instruments
I’m having a bear of a time adding instruments. I’m running 1.0.30 on a Mac.

I understand the process of adding Players to an existing Flow in Setup. When I do, Dorico will not trigger any notes in HALion, even if all the assignments have been made in the VST Instrument configuration (program loaded, MIDI channel assignment in the cog dialog, etc.). In fact, the same holds true when using Kontakt and going through the same process of assigning the VST Instrument and the MIDI channel.

What I have observed is some strange behavior, which may be an indicator of what’s happening:

In the Dorico Mixer, when clicking on the “VST Instruments” button, Dorico will clear the VST Instrument assignment for the new track and will reset the MIDI channel assignment. The Mixer will actually never reference the new instrument/track in the channel, from which I take it that something has gone wrong with how Dorico added the new instrument.

The only time that Dorico is assigning instruments properly is when creating a new score and choosing the desired instruments right at the beginning.

Anyone run into that issue?

Attached are a couple of screen shots that show the issue.

I think you may have a step missing here. The cog icon in the VST panel doesn’t assign instruments to a plugin, it sets up the expression map (which tells Dorico how to convert Playing Techniques into keyswitches, etc). The assignment of an instrument to a plugin is done in the ‘Track Header’ in the left side of Play Mode (where you have ‘Trombone’ followed by ‘—’).

However, if you are using the default HALion sounds then you shouldn’t ever need to do this by hand. I have just tried this now and I can’t reproduce the problem. I created a new score and then added an oboe player using the ‘Add Solo Player’ button in Setup Mode. The new instrument show up in the mixer as ‘HSSE Oboe’.

Can you describe the steps that get you into this state?

You should find that Play -> Load Unassigned Instruments will ensure that these other tracks get assigned, or you can do Play -> Apply Default Playback Template to do a reassignment for all instruments.

I must admit that I find I have quite a similar problem… The instruments I added do not “expand” in Play mode. It is so with the score I sent to Daniel and he helped me with problems I had with empty (not that empty) staves not hiding. I had to mess a lot with MIDI channels assignments to get those instruments to work, and still the window will not expand (see attached picture). And I KNOW I added those singers after completing first flow (piano only).
[Edit before first sending] While taking the snapshot, I discovered that the view in Play mode is Flow dependant, and if you do not change the flow (top left), it still shows the first flow state — in which, obviously, the singers do not appear, they are not present there. What is tricky is that, if I launch play in play mode in the 8th flow (which is an ensemble, everybody should be present), the play window do not update its view. But if I choose the 8th flow, then everything is as should be. Maybe some improvement here is needed ?

Thanks, Paul. I think there is an issue with a particular set of steps that causes Dorico to exhibit the issue. I will document it below using screenshots. However, in summary, if one starts with a blank project and not one of the templates, adding a single player with an instrument, then delete that single player and adding any subsequent adding of instruments or ensembles, Dorico will create additional instruments in HALion SE starting with the next MIDI channel. I’m sure that is by design, but is where the problems start.

See if the following can be reproduced on your end. I am attaching a ZIP file link with the screenshots for the steps.

Step 1:
Create a new project, adding a single Horn player to the project. Added some notes. Everything played back and looked normal.

Step 2:
The single Horn player is deleted using the “Delete Player and Part Layouts”. This will cause Dorico to delete the Player and the Part in the Layout, but will not delete the HALion SE instrument.

Step 3:
Add the single Horn player back to the project. Dorico will add the Part in the Layout and will create a new HALion SE instrument for the Horn, starting with MIDI channel 2 and leaving MIDI channel 1 in place. That could very well be by design.

Step 4:
Thinking that I already have a Horn instrument in slot 1 in HALion SE, I delete the Horn instrument in slot 2, and re-assign the track in Play for the Horn from MIDI channel 2 to 1. Everything plays back as expected and things are good so far.

Step 5:
This is where the problems start. Adding an Ensemble, in this case Strings, will cause Dorico to add the Staves in the Layout, but will not create new instrument slots in HALion SE and will therefore not having anything to assign in the Stave Tracks on the Play tab. Any attempt to manually add them to HALion SE and assigning the MIDI channels in the Tracks will not result in Dorico playing any notes added to those string Staves. In fact, I have seen Dorico actually reset the HALion connection, including the MIDI channels I have set up manually.

Hopefully the above makes sense and can be reproduced. From it I gather that we best not mess with how Dorico sets up instruments in HALion SE, but I think there is a fundamental problem, as the above can easily cause issues down the road as a score is worked with. (1.59 MB) (786 KB)

As soon as you make any change in the assignment of instruments to channels in HALion Sonic SE in Play mode, Dorico no longer feels as if it has the right to do anything further automatically for you: since you’ve started changing settings in Play mode, it assumes that you are going to handle the assignment of instruments to playback devices yourself from that point on.

If you want to put things back to a sensible default state, choose Play > Apply Default Playback Template, which will cause Dorico to reload all the sounds it thinks you need for the current set of players and instruments, removing any unused ones, but also, of course, overwriting any changes you have made to the various sounds within HSSE.

Thanks for taking the time to list the reproduction steps. There is indeed a bug here, though there is also some intentional behaviour, as Daniel notes.

When you change the routing of an instrument (as you did for the second horn) Dorico turns off its automatic routing of instruments, because otherwise it may overwrite changes that you’ve made to your plugins (it can’t know what you have changed, so it chooses the safe option of not doing anything). So it’s intentional that any instruments you create after that point will not be assigned automatically.

However, it seems that there’s some internal data missing from instruments that are created after this point, so that even when you try to route them manually they won’t play back. I’ve logged this as a bug and we’ll aim to look at it for the next update.

EDIT: I have now fixed it!

Thanks, Daniel and Paul! I assumed that Dorico’s behavior to disable automatic instrument routing when manually changing assignments is intentional. That’s reasonable, of course, as long as the user understands that is what’s happening in order not to add confusion into the mix. :slight_smile:

Paul, I assume that the fix you implemented addresses the resetting of all manual assignments in the Play tab to where the manual assignments persist for the VIs and MIDI channels. It’s not just that new manual VIs don’t play, but the assignments are completely reset for the manual assignments (as in empty) when making further changes. I can demonstrate, if this is not clear.

Looking forward to the next release. Appreciate all you and your team are doing to make us happy!

Hopefully it should fix that issue because the internal data previously wasn’t created, so the routing could not be set (however, the UI appeared to let you set it).

There are two aspects to the fix:

  • After changing the routing, any instruments created after that point can now be manually routed
  • For old scores where you’ve done manual routing already and the internal data is missing, Play -> Load Sounds for Unassigned Instruments will fix it so that you can then route it.