adding players and score order

I start a new project with one instrument (let’s say piano)
I add one or more players
the new instruments appear on the bottom of the players panel on the left as well as on the layout panel on the right
I want to change the order of the instruments, I drag the new ones on the left to be above the piano, but nothing changes in the score
I do the same with the layouts on the right, but that doesn’t change anything either
how do I re-arrange the order of staves?
Is there something that doesn’t work or am I doing something wrong?

You should certainly find that dragging the players in the Players panel in Setup mode changes the order of the staves in the score. You can also use the keyboard shortcuts Alt+up/down arrow to move the selected player(s) up and down the list in the panel.

Yes, I know, but neither method works. Attached a test - I opened a Dorico template (piano) and added one player (guitar). I can not move the guitar to the top. That is, I can move it on the left in the players panel, but that move is not shown in the score (neither galley nor page view). I attach the file. Well, that didn’t work … (I’ll email it directly)

You can attach projects if you zip them up first, provided they don’t end up too big (I think the size limit is something like 3MB).

Regarding attachments it says - If you wish to attach one or more files enter the details below. (.jpg, .gif and .png allowed). When I zip a file it becomes a folder with a .zip extension, but that can’t be attached either (and it is only marginally smaller than the .dorico file (210 vs. 212kb).

I think I’ve figured out what another problem was (not seeing any instrument staff names, forgot to mention this) - in Setup / Layout Options - Staves and Systems - Staff Labels were set to None (not by me, though, as far as I remember) and in Players Custom Order was checked (I may have done that inadvertently when attemptng to move instrument staff positions around - however - are these GLOBAL settings that then apply to all projects?)

somewhat later - the fault seems to be with the templates - I’ve checked several and they all had players / custom order selected, thereby inhibiting the moving around of the instrument staves - I guess they are of course fixed instrument groupings, but as soon as one wants to add an instrument it can’t be positioned correctly in the score, unless one happens to find that setting. By the way, this is also the case when opening a new, empty project (shouldn’t that perhaps be changed?)

P.S.: still would appreciate to know how to zip and attach files

To zip files, I would recommend 7-zip. Once you’ve got it installed, simply right-click the file you want to add to a zip file, and choose 7-zip > Add to Archive from the context menu (from memory, the exact wording might be slightly different – I use Windows as infrequently as I possibly can these days), and make sure that the zip format is set to ZIP rather than 7z (it will remember this setting so you don’t need to make it again in future). That will make a .zip file alongside the original file that you can upload here.

The problem you’ve got with your layout options is caused by having clicked the ‘Save as default for X’ buttons at the bottom of the Layout Options dialog, which is the cause of quite a few subtle problems. To undo its effect, in Windows Explorer go to %APPDATA%\Steinberg\Dorico (you can paste that into the address line), and then delete the files called layoutOptions_scores.xml, layoutOptions_parts.xml, layoutOptions_customScores.xml (not all of them might exist, but delete the ones that do). That should make new projects behave better from now on.

Actually, I do use 7-zip. I’m attaching a file created via “Add to …” to see if this works (210 KB)
I deleted the layoutOptions_scores.xml. The moving around of instruments works fine. The templates are, however, still set to “None” in Staff labels in Options. Is that intentional? (might only be the Solo templates …)
Re adding an instrument/player, specifically a clarinet - why is there no Clarinet in Bb no key sign (as it exists in Trumpet)?

P.S.: Attaching seemed to work, but never mind the file, it’s already been corrected and works as it should.

Yes, it’s intentional that the solo templates don’t show any staff labels by default.