Adding slurs turns Note Input on?

Perhaps my workflow is flawed-- anyhow I am trying to put slurs in existing music, but every time I click on a note, then S to enter the slur, Note Input gets turned on and I have to ESC and then click on the next group of notes to slur.
Is this a bug or a feature? Or is there a better way to do this (when composing I do not know in advance which notes I want to slur).
Using the arrow keys is also not an answer-- after entering a slur, the right arrow key happily jumps not to the next note but to the next slur in the line, which defeats the purpose!

It sounds as though you’re using pitch before duration. Either hit K to toggle off pitch before duration or click the select tool (the mouse pointer towards the top of the left panel) to turn off mouse note input.

Thanks for the speedy and useful reply!
(Not quite sure what the pitch/duration toggle should have to do with the selection process though… but I appreciate the hint!)