Adding track using track presets doesn't add anything

Win x 64 / Cubase 8.0.20

1 - Project > Add Track > Using Track Preset
2 - Choose your preset
3 - Nothing happens. Nothing.

4 - Add a track
5 - Right-click on Track > Load Track Preset
6 - Choose your preset
7 - Preset loaded

As you can see in this capture

I watched your video and tried this.Clicking in the empty area did nothing, but clicking on the text of the name of the preset did work as expected, and double-clicking also did.

Can you try that?

I clicked in the empty area to show it wasn’t loading. As you can see at the end of the video, loading the preset with 6 Nebula instances takes quite a while :wink:

This is what i do in the video : i double-click on the name of the preset on the first try, and i click on the name then click on Add on the second try. Neither work…

Hm. Maybe there is more to it, it is working here. Maybe someone else can repro.


I cannot reproduce ti neither on Mac or PC, some presets take a little bit longer to load than others but they eventually load, perhaps a second and a half but they all load, I tried MID track presets, audio track presets, instrument track presets.

Please start Cubase in safe mode and see if that fixes the problem.

All of them are loading.

Best regards,