Adding VST2 to the whitelist

I have been using Dorico since day 1 and love it but am only now attempting to add VST2 plugins to the whitelist as outlined here:

However, I am confused by steps 3 and 4 in the instructions because I see nothing there or in my own Defaults.xml file indicating which digital string ID belongs to which plug-in. For example, in the example provided in steps 3 & 4 the string apparently relates to Kontakt 5 (see step 5) but how can a user can know that from the non-specific information outlined in step 3 or the similar examples in my own Defaults.xml file? Clearly, I am missing something but I’m not sure what that might be.

I think it’s as simple as adding the VST name to your whitelist (take care the name is correct, it’s sometimes different between Mac and Win) and adding 32 zeros on the line beneath. (You don’t need the exact number anymore). Trash the defaults.xml and restart Dorico (maybe reboot the machine first as well…)

Unfortunately the information given in the mentioned Steinberg link is outdated. Since version 1.0.30 it became much simpler, as already outlined by user Fratveno.
I’ve already provided our Support with the new, pertinent information but obviously they have not had the time, yet, to update the website. Hopefully they will do soon. I might give them a little kick…

Thanks fratveno and Ulf. It is great that the process is now more simple and I will try again tomorrow. I suppose if there is some question about the recognized name of a plug-in, the firm producing it is the party I should contact.

You shouldn’t need to consult the manufacturer if you’re not sure about the proper name for the plug-in: it really should just be its filename as found in /Library/Audio/Plug-ins/VST without the “.vst” extension.

And if we are already at it…

With the upcoming Dorico 1.1 update things will become even more simple:
That daft 32 digit number is not necessary anymore at all, just list the plug-in names, that’s it

Furthermore, people complained that our update installers simply overwrite their arduously edited whitelist.
True, very dumb. So you then will have the possibility to have an own, second whitelist at a location that the installer will not touch. The name of the file needs to be same (vst2whitelist.txt) and goes to
Win: C:\Users<username>\AppData\Roaming\Steinberg\VSTAudioEngine_64
Mac: /Users//Library/Preferences/VSTAudioEngine

But again, this will be from Dorico 1.1 onwards!

Thanks Daniel and Ulf. I have been partly successful and will keep trying - hopefully overall success is close at hand.

I was indeed successful getting my VST 2 plugins working in Dorico on the computer I was using at the time. However, I have moved to a more powerful, updated machine and am again having problems although I followed the same steps with my latest machine, a 2013 MacBook Pro 15". The VST 2 plugins I have added to the whitelist are Pianoteq 5 and the 7 reverbs in the Lexicon PCM Reverb Bundle. The Pianoteq 5 plugin shows up and works fine as a virtual instrument. However, none of the reverbs show up as an insert in the mixer in spite of repeated attempts and double checks that the names are properly entered, etc. Also, the reverb plugins show up in Cubase 8 on the new computer so they are definitely loaded onto the computer. Also, show up fine in Dorico on my earlier computer. Suggestions?

Did you install both pianoteq and the effects in the same location?

Just a quick thought or two (apologies, haven’t read the whole thread) - sometimes, with certain plugins/instruments, there is a restriction on how many (physical) installations are allowed. Is it possible you’ve hit this barrier…? i.e. you may need to fully uninstall/deactivate from one of the other machines first… I’ve read this can be the case when iLok licensing is involved, controlling authorisations etc…

Response to fratveno:
Yes. Both plugins are installed to the same location and both plugin names are entered into the same whitelist. The plugin and whitelist locations are also the same as identified in the Steinberg form re VST2s in Dorico and the same as in my “other” computer in which they both work as they should. There must be an answer but it is certainly confusing me as to what that might be!

Response to Puma0382:
I did come across this situation concerning some plugins and had to deactivate them from a long-abandoned computer. However, that doesn’t appear to be the case here, especially as the Lexicon reverbs do appear as plugins in Cubase. I suspect the problem relates somehow to Dorico’s VST2 whitelist situation, although I have checked and double-checked every step and haven’t seen anything amiss.

Thanks to both.

You might want to try running the clean-up script linked to in the FAQ thread, which should give a nudge to the audio engine to rescan all your plug-ins.

Thanks, Daniel. I downloaded the clean-up script but don’t know what to do with it. I then looked up “clean-up script for Mac OS X” and this gave me many results but none that appeared relevant. Is it easy to tell me how to run the script or are there instructions you can point me to?

Open a Terminal window (you can just type “term” into Spotlight and hit Return). Make sure you have unzipped the zip file containing the file called Drag the unzipped file into the Terminal window. You should see the path to and the name of the script appear on the command line in the Terminal. Hit Return to execute the script.

Thanks, Daniel. See my more complete response here:

Before running the clean-up script I tried erasing the contents of the whitelist which, as expected, left no VST2 plugins available. I then re-added the whitelist content and restarted Dorico but my Lexicon reverbs were still not visible or available. I then dragged the clean-up file into Terminal and hit Return but got an error message advising the clean-up file doesn’t exist - a screen shot of the Terminal message and the clean-up file is attached. I’m unsure what I can try next.

The fact that after clearing and re-editing your whitelist the other plug-ins appear, shows already that the audio engine did a scan of the plugs again, so running the clean-up script would not make any difference.
Could you please zip up the folder /Users//Library/Preferences/VSTAudioEngine and post here? From the log and other files I hopefully can see what the trouble is. Thanks.

I have attached the zip file. Thanks for looking into this for me. (436 KB)

Thanks for the data, Mike.
Actually, the audio engine does recognize your Lexicon plug-ins, but the plug-in sentinel refuses them and puts them on the blacklist. And to be honest, I have no idea why they do get blacklisted. I’ve googled and could not find any general issues with the Lexicon plugs, also not in Cubase. Could it be that they are only 32bit plugs, as those will be in general refused?
You could try following: That VSTAudioEngine folder that you zipped up for me, delete it completely, then restart Dorico. The audio engine will recreate the folder automatically and also will scan for plug-ins again. Let’s see if that might rectify things, but I have few hope. Please then zip up the folder again and post here.

Hi Ulf and thanks for your help! I deleted the VSTAudioEngine folder and then restarted Dorico and had partial success - the previously “missing” Lexicon reverb plugins now show up as being available in the mixer and when selected, their window shows up on the screen. However, no signal goes through them and they have no audible effect on the output - they aren’t actually functional.
The webpage for the plugins (the Lexicon PCM Native Reverb Bundle) identifies the Windows version as being 64-bit but is silent with respect to the Mac version but past experience leads me to believe it is 64-bit as well. One other aspect that seems strange is that the reverb plugins work fine in Dorico in my other computer that I will shortly retire. Apart from greater processor speed and more RAM, the other difference between the two is OS X 10.10.5 Yosemite on the older machine and OS X 10.12.4 Sierra on the newer one.
I have attached the VSTAudioEngine folder from after the Dorico restart and a subsequent restart of my computer after I discovered the reverb plugins weren’t functional. (436 KB)