Additive Drums 2 interface not working with Dorico 4


For some reason Additive Drums 2 is not working with dorico 4 - the interface is just a black screen.

It still works in dorico 3.5 and I can set it up there on then open the project in dorico 4. That way I still get the sound out of it, it’s just the interface that is black:

This happens also for newly created projects in dorico 4. All the other plugins I tried seemed to work normally.

I have an intel mac:

Screenshot 2022-01-15 at 14.15.56

I guess this will come down to being a problem of some kind with the VST audio engine, since Dorico itself doesn’t show plug-in interfaces at all. Paging @Ulf, who will hopefully have some idea.

Hi @SampoKasurinen , to be quite honest, at this moment I have no clue how that might can happen, but we will try to figure it out.
Please do in Dorico ‘Help > Create Diagnostics Report’ and post the corresponding zip file here, hopefully the logs files will tell something.
Do you have other audio apps that load that plug-in? No problem on that end either, I guess.

Thank you for the help!

Here is a diagnostics report:

Dorico (1.5 MB)

I tried every vst instrument I have, all the others work normally but both Additive Drums 2 and Additive Keys show just a black interface. They open normally both in dorico 3.5 and cubase 11, so something must have been changed with dorico 4. Or perhaps my installation is corrupted?

Hi @SampoKasurinen , I have just installed the trial of Addictive Drums with me and it shows up properly. According to the logs you have version, but I have here Maybe an update would help…

Good to know, I will update everything and see if that fixes the problem!

Thank you for checking this!

I’m happy to report that updating additive drums to the latest version solved the problem. Many thanks for the help!

1 Like