Adjusting MIDI Note Overlap Behavior in Cubase

Hello Folks.
I’ve encountered a behavior in Cubase that differs from my experience with Ableton. Whenever I input new MIDI notes or duplicate existing ones, they tend to overlap instead of replacing the previous notes. This overlapping can be quite exhaistomg to manage. Is there a setting within Cubase that allows for newly created or pasted notes to automatically cut off or replace the prior ones, avoiding any overlap? Any guidance on adjusting this in the preferences or elsewhere would be greatly appreciated.

Best regards,

Hi,

No, there is no setting. But there is a function to Delete Doubles.

Hi Martin. Thank you for the Prompt Answer.
Are you refering to this fuction
image

I ran some tests and there’s a big issue. It doesn’t make sure the notes left are the newest ones. I tried it with some old notes that always have the same velocity, and in the first bar, I put notes with different velocities. Then, I copied this first bar to the second one. So, in the second bar, I got overlapping notes: the old ones with the same velocity and the new copied ones with changing velocities. I thought the ‘Delete Overlap (mono)’ function would keep the newest notes and get rid of the old overlapping ones, but it didn’t work that way. This makes it kind of useless for what I need.

I think I’ve discovered the solution, and the option you mentioned is indeed effective. It’s found under the menu path: MIDI > Functions > Delete Double. It works flawlessl

1 Like