After enabling a Disabled Track, midi Inputs are lost

After enabling a Disabled Track, midi Inputs are lost if that track was Duplicated from another Disabled Track.
Cubase Pro 8.5.15
Steps to reproduce:
1-Create an Instrument track with your favorite Instrument (Kontakt in my case)
2-Make sure the midi input is set to: “All MIDI Inputs”
3-Disable the track
4-Duplicate the track
5-Enable the newly duplicated track.
6-Midi inputs will be missing.
7-Enable the original track
8-Midi inputs will be missing as well.

Thanks

Hello,

This is a known issue, we are currently working in a solution.

Best regards,
GN

The bug is still there after 8.5.20 update.
Just to let you know…

Hello,

Sorry but no, I cannot reproduce this on Cubase Pro 8.5.20 and it seems many other users have confirmed it is now fixed. Delete your preferences, open the old project save it, close Cubase Pro 8.5.20, open the project again and the problem should be fixed.

Best regards,
GN

Hi,

I am afraid this problem is not fixed. I made this short video earlier today and have spent a few days of my life trying to figure out what is wrong. Hope this helps as I need this feature to work as advertised.

Many thanks

Jono

https://www.youtube.com/watch?v=Kq38dA3Q9p8

I also believe there are still problems with disabled tracks. It doesn’t look quite the same as presented by Jono, but it could be. This sequence shows up a problem on my setup (on Cubase 8.5.2)

  1. Create a new project
  2. Add an instrument track with an instance of HALion Sonic SE (Track 1)
  3. Load an instrument in channel 1 so we are sure which instance we are using (1965 Combo)
  4. Add a MIDI track connected to the same instance (Track 2)
  5. With track 2 selected, note that hitting the ‘Edit Instrument’ icon in the inspector opens the instance of HALion
  6. Disable Track 1
  7. Save project, close, reopen (Hit cancel at Missing Ports dialog when opening)
  8. Add an instrument track with an instance of HALIon Sonic SE (Track 3)
  9. Load an instrument in channel 1 so we are sure which HALion instance we are using (1984 Synth Stab)
  10. Add a MIDI track connected to the HALion instance (Track 4)
  11. Disable Track 3
  12. Save project, close, reopen (Hit cancel at Missing Ports dialog when opening)
  13. Enable Track 3 and Track 1
  14. First note that clicking the ‘Edit Instrument’ icon with either MIDI track selected will not now open an instrument.
  15. Note that Track 4 Output routing now says 01 HALion Sonic SE (ie The first instance HALion not the second one)

Is anyone else able to replicate this please?
Thanks, Ian

Hello,

Did you created that template from scratch on Cubase Pro 8.5.20, or is it an old template and you just opened it on Cubase Pro 8.5.20?

I just want to make sure before reopening the issue.

Best regards,
GN

Hi,

Yes. I made this template from an Empty Project, in Cubase 8.5.20 and I trashed Prefs before starting.

I have continued to build a template using Instrument tracks and Midi tracks for when this problem is fixed so I can use the disabled Track feature (I can only imagine how great this will be)!

Thanks

Hi guys, i just switched to Cubase Pro 9 (from another DAW) and I also encounter this issue while setting up my template. I found out what is causing it for me, and filed a new issue report with my findings: https://www.steinberg.net/forums/viewtopic.php?f=253&t=120675. Please see if you recognise it, and add your comments so this can be finally fixed.

Still an issue on a new template, fresh preferences.

Cubase 10.5.20.

same here, cubase 11, from a new empy project