After recording MIDI, I cant listen to it unless I enable to record that track


After recording a MIDI track , I cant play it back unless I enable to record that track.

I have been trying to figure this one out for a week now.

I upload halion into an instrument track, I have my MIDI controller connected, I can hear and play normally while I have the track enabled to record, BUT as soon as I stop recording and I deselect the track I cannot hear it when playing back.

My audio setup is all well connected, I think, and I can hear everything else in the software.

If somebody knows whats going on I would appreciate some help.

You need to enable the Monitor button on the Track. Not at DAW to post a pic, but it looks like a small speaker.

Yes, I have tried that, but then when I record other tracks, I will hear every track that has the Monitor button turned on…

Is the MIDI Track output routed anywhere ?

Yes, when I open the mixer it is routed to the stereo out track

And this problem is just with MIDI tracks. With audio tracks they playback just fine.

This doesn’t answer my question… a MIDI Track doesn’t have an audio output but a MIDI output, it has to be routed to an Instrument or a MIDI device.

Is the problem with MIDI Track or Instrument Track ?
Can you please post a screenshot of your project ?

Sorry, my bad. I was referring to instrument tracks.

Thanks for the screenshot.
Tbh I have no clue on this one, once the MIDI has been recorded you can normally playback the instrument without enabling monitor, just like with audio tracks.
Does that happen in other projects too ?

Yes it does. I tried to check every possible preference there is in here.

Oh, and also before I had this pro version of cubase, the same happenned on elements. So I must be doing something wrong.

Perhaps this has to do with MIDI channels.
When you monitor I believe it uses all channels, but the recorded data is still a single channel (the one set and sent by your controller), and if it’s not the same as the one in HALion it just won’t play on playback. Just try changing the channel until it plays.

Just to verify I understand correctly - you’re saying that on the Top Track, the one with the MIDI Part on it, when you play it, that MIDI Part doesn’t cause the VSTi on the Track to produce Audio? If that’s the case then like @Louis_R says it is likely an issue with MIDI Channels.

You could use the MIDI Insert MIDI Monitor to see what is being sent to the VSTi.

If you continue to have the problem, could you post another screenshot except have the top Track Selected so we can see its Inspector settings.

Thank you for helping me.

I uninstalled everything and reinstalled.

But it didnt change anything.

MIDI Channel Insert 1 - MIDI Monitor 17_10_2022 22_43_12

When I playback, the MIDI monitor registers every note.

About what Louis said, I didnt quite understand…

The screenshot in this post shows there are no audio outputs connected?

Good eye. But it says the Control Room is connected and that usually implies the Outputs are not going to be connected.

What I find puzzling is that the Input/Output Connections Status are not even available to be displayed on my DAW.

@Maximo_Francisco In your latest screenshot one of the MIDI Parts looks like it is selected, but on the Info Line it says that nothing is selected. Do you know why one of the Parts looks different from the others? Perhaps some are muted?

I have looked into muted parts but it is not that. In the previous screenshot it does have a different color but I didnt know why. But as you can see in the new one, it is not muted.

In this screenshot I was playinback the tracks at the same time (you cannot see the cursor but it is playing both E-piano and retrologue) and while doing so it only trigers the MIDI track which has the record button turned on. Maybe that says something to you…

In the meantime, my input/output is also gone from both Hidden and Visible items :slight_smile:

Oh yes, I missed the control room is connected, So eye not so great after all :rofl:
I think the in/out/cntrl status is something that automatically shows up when nothing is connected or there is a configuration error. I cannot choose to have it shown either, but if I open a project, then open Audio connections tab and remove control room output, then save project, and close it, When I then reload the project it appears automatically. :slight_smile:

Yeah that’s some sort of bug since 12.0.30, when all connection types are connected it removes the entries, but if at least one isn’t connected it shows them all.

ah okay, but I never have outputs connected, just control room, And it only appears for me if I remove those? :slight_smile:

Well that’s what I have noticed when loading different projects, but then it seems to be different for everyone.

1 Like