after writing automation, solo does not turn off correctly

after I write automation on some tracks, when I solo a track and then try to un solo the track there is another track that solos or the track I am on does not unsolo without using “all solo off”
Is there a setting for this somewhere?

When I write a mute on a track this happens. It seems to only happen when I automate a mute on another track. Often when I solo another track the track I have selected as well as the track that had the mute automation both solo. then I have to use all solo off to go back to listening to all.