AGAIN -eLicenser Control - Error

This is getting so tiresome. After several weeks of having no problems I’m facing them again.

I’m playing by the rules. I have my USB eLicenser. With this latest series of errors, I’ve updated to the newest control center. I’ve done the maintenance and everything is supposed to be OK but the problem persists.

Why hasn’t Steinberg addressed this issue? Dorico won’t even launch!!!

Restart, maintenance… no joy.

Complaints about the irritations found in Sibelius and Finale abound but now I’m facing one of my own with Dorico - one that makes me find using Dorico less and less enjoyable with each appearance. It’s not a good feeling.

Dorico - 3. (lastest version…)
eLicenser Control Center:
Mac OS 10.14.6 (Mojave)
16 GB ram.

When you run into that kind of exception, you may well find that rebooting your computer is the quickest way back to a clean slate so that the whole eLicenser subsystem is cleared down.

We’re more than aware of the issues that users experience with the eLicenser system, and as we’ve said many times, we are actively working on a replacement license management technology. But developing this system will take time, and we beg for your continuing patience as we work towards the introduction of a new system.

Thanks, Daniel. Having someone who acknowledges the problem helps. BUT… I HAVE restarted the machine and more often than not it doesn’t resolve the issue. It’s truly baffling what’s going on. Why should Dorico 3 perform flawlessly for weeks and then suddenly have this issue? Nothing has changed… no OS updates, nothing… just Dorico acting wonky. One becomes shell shocked and just trying to launch Dorico becomes an exercise in fear - will it work? What gymnastics will I have to attempt to see if I can get Dorico to launch…

Your screen shot says that the Soft-eLicenser threw an exception, on the other hand you say that your Dorico license is on a USB dongle.
If you open the eLCC, does it show a Soft-eLicenser and what licenses are on there?

I would try moving the Soft-eLicenser temporarily out of the way and see if that makes a difference.
Therefore, rename the file
/Library/Application Support/Syncrosoft Soft-eLicenser/SeLicenser.sel
to e.g.

Reboot the machine and see how it then behaves.

thanks for the suggestion, Ulf, i’ll try that. as to your question regarding the eLCC, please see the attached screenshot.

Ah, if I interpret that correctly, then your Dorico license is on the Soft-eLicenser and not on the USB-eLicenser. In that case my recipe won’t help, because you then won’t be able to start Dorico anymore at all. If you did, then simply rename the file back to it’s original name. Then run the eLCC and perform the Maintenance task. That shall bring back the Dorico license.
If you still have startup trouble, I need to consult our eLicenser guys when back to office on Monday.

Well, if that were the case Dorico 3 would presumably launch without the USB-eLicenser inserted… and yet it doesn’t. I have to insert the USB-eLicencer otherwise I get the following:

In the eLCC screenshot you posted yesterday, you had the ‘All licenses’ entry selected in the left-hand list. To tell which eLicenser (Soft- or USB-) your Dorico license is installed on, select the specific eLicenser in the list: only the licenses that are installed on the selected eLicenser will then appear. It certainly appears that your Dorico license is on your USB-eLicenser.

here it is:

Indeed, as I thought. I’m happy to provide you with a time-limited Dorico Pro 3 license you can put on your Soft-eLicenser if you like. Then you can disconnect your USB-eLicenser for a while and see if you find that any more reliable.

I’ve the same problems (and more) with the eLicenser. I’m having them since when first installing it for using VSL libraries, at the end of 2016. I’ve changed three computers in the meantime (Mac mini 2011, Mac mini 2012, MacBook Pro 2015), and two operating systems (Sierra, High Sierra).

During these years, the only hints I could receive were to force-quit, restart the Mac, connect the key to a different USB port, use a self-powered hub, use USB 2.0 ports instead of USB 3.0.

None of these hints completely solved my issues, that are continuing everyday, with both Dorico and VSL products. Dorico also adds the problem that you sometimes can’t simply restart some software, but you have to entirely reboot the Mac.

I can’t exclude there is some issues in my hardware/software configuration, but since I’m not the only one to have them, I allow myself to think that there is something wrong with the eLicenser.

Dorico is a great software, despite the youth problems. As is VSL. eLicenser is a pain. Isn’t really an alternative to protect the developer right to protect their software, and the right of the user to use it without embarrassing workarounds?


Thanks, Daniel, I might take you up on this offer.

Some questions though:

I run Dorico both on my desktop and on my laptop using the USB-eLicencer to do so. I’m having the described problem (so far) only on the laptop. If I use the offered ‘time-limited Dorico Pro 3’ license, how long is the limited time? Also, my presumption is that this wouldn’t affect how the USB-eLicenser containing my own license works with my desktop machine.

In any case, I might have discovered a workaround. In my last attempt to run Dorico 3 on my laptop, I ran into the eLicencer error described. I had to force quit Dorico and then go into the Activity Monitor and force quit the VST engine. I pulled out the USB-eLicenser and on a whim relaunched Dorico 3 thus generating the notice that no valid license key was found. When this window popped up I re-inserted the USB-eLicenser and clicked the ‘retry’ button. Dorico 3 launched without an error. I don’t know if this is a real solution but I will report on its success the next time Dorico fails to launch with the USB-eLicenser inserted.

I think what you experienced with inserting the USB-eLicenser after Dorico launched is just a coincidence, I’m afraid. I can provide you with e.g. a 90-day license that will allow you to run Dorico without connecting your USB-eLicenser and see whether it is more reliable. This wouldn’t affect your USB-eLicenser, so for the duration of the time-limited license you could still use that on your desktop computer as you currently do.

thanks, Daniel. ok… let’s go that route and see what develops.

I’ve had similar USB dongle errors on my 2015 MacBookPro, but not on my latest superfast Mac Pro.
So these error messages are most certainly part of overall hardware issues.

I solved the problem on my laptop, by installing the very latest version of the eLCC and having it open at all times.
After that the only issues I’m occasionally experiencing is Dorico LE booting intead of Dorico Pro, but that’s all.

On my beast workstation Dorico has been booting flawlessly ever since.

Don’t know if my experience is relevant to others posting on this topic.

Every few weeks or so I get eLicenser errors with my USB-eLicenser on my 2010 MacBook Pro.

I’ve experienced problems with several of the ports on this computer: both of the USB ports, the SD card port, the firewire port, and the headphone port.

It may just be wear and tear on ports that have been in daily use for nearly 10 years, but I’ve also found that the ports tend to suffer from an ingress of fluff, and that a gentle clean-out of the offending port generally helps with the USB-eLicenser problem.

Worth checking.

Just to add to the conversation, I’ve found when dorico is running and I then put my pc to sleep, when I wake the pc, connection to the elicensor is lost. Dorico becomes unresponsive and doesn’t exit cleanly (force quit, reinsert dongle). This never happens in cubase (although I will double check that again).