Airpods suddenly not working/appearing in device setup

My Airpods were working just fine until suddenly they weren’t. I put them away in the case to go do something, and when I came back they won’t accept output from Dorico, and don’t appear in device setup; the only output device appearing is my laptop’s speakers. I have tried restarting Dorico, unpairing and re-pairing the Airpods, reinstalling the Bluetooth drivers, reinstalling Dorico, and restarting my computer, all to no avail. Also unfortunately I don’t have any other Bluetooth headphones to test to see whether the issue is with the Airpods or with Dorico. Does anyone have any fixes? Thanks!

Did you go through the Apple things?

And did you check the sample rate of both, Dorico and the AirPods? The sample rates must match, otherwise Dorico won’t show the AirPods as output device.

They don’t match: the generic ASIO driver is at 48k and the Airpods are at 44.1k, with no other options for either. I forgot to mention I’m using Noteperformer, but I tried changing to a different playback template to see if the Airpods would show up, and they didn’t. I don’t know why the sample rates would suddenly change/cause the Airpods to not work, although that’s definitely the problem.

Then try the following: Switch Dorico to use the built-in sound device. That one should be able to handle both 48 and 44.1 kHz. Then you switch from within Dorico that built-in device to 44.1 kHz. When that is accepted try switching to the AirPods again.

How do I do that? The only option I have is the built-in laptop speakers (which is what I think you meant by the built-in sound device), and the only sample rate option is 48k. I have some pictures:

I finally changed all my programs to 48K since some program (Cubase? VideoStudio? Windows updates?) kept resetting the sample rate to 48K. Although I have to remember to check carefully to specify 44.1K and 16-bit when exporting audio for CD, I found that keeping everything at 48K made everything a lot easier and more predictable.

Then let’s try something else:
Stop Dorico from running and go to the Windows Sound Settings as outline in this thread. Only difference, choose the Realtek device and then follow the way to the advanced settings. There where the options for exlusive access are is also the option for the default format. Choose 44.1 kHz / 16Bit, apply and close. When you then start Dorico, does it come with 44.1 kHz. If yes, then you should be able to switch over to the AirPods.

The first time I started Dorico after doing this, I changed the ASIO sampling rate to 44.1k and then nothing appeared in the ‘stereo output’ section in device setup, and when I tried to select the Airpods in the device control panel it wouldn’t save after leaving the menu. I quit out and tried to start again, but the audio process died, so I had to stop Dorico through Task Manager. I started Dorico again, and now both show up and the Airpods are selectable and are working again. Thanks a lot, Ulf!

1 Like