Akai MPK249 - knobs and pads not following mapping in Cubase 12

I have an Akai MPK249 going through M-Audio 2x2M and running PC windows 10. I did all the mapping to create a proper script, easy as. But nothing seems to work. Transport does work once, then doesn’t anymore, e.g. I press PLAY, it plays, then STOP, it stops, then PLAY again, it doesn’t do anything. When pressing REWIND, I can’t stop the cursor from rewinding since I pressed it once already.
When I turn one knob, three knobs turn at the same time. Some pads (assigned to pre-roll) don’t do anything. I have deleted the script already once and started from scratch again, but to no avail. Anyone had the same trouble?


Did you setup the buttons properly as toggles or not, please? What happens, if you press: Play, Stop, Play, Play. Does it play then?

Hi, What do you mean as Google’s?

i got a mpk249 as well , to work around the transport buttons issue , use the transport buttons in the key commands category instead of in the transport category , and map those to the transport buttons on your mpk249 it should work fine , also when mapping buttons in midi map editor make sure to select the right mapping scope , ie global and not project only , click on the G button to change and select .Also i think the new 12.0.20 update addresses these issues . To stop multiple knobs turning at once use the selected track option in midi mapping editor
cheers !!


Sorry, autocorrection… I mean as toggles.

Cool mate, so far, the trick with the key commands works. A bit trickier with the pads though, I need to keep working on those. Where do you find the G button? Hey it looks like you’ve created a script with three times the knobs and faders, like one for each bank, is that how you did it?


I just realized, the Pads are sending MIDI Notes with the volume (depending, how hard do you hit it). In this case, I would trigger the action only when Volume 0 had been received. This would trigger the action when you release the Pad.

yeh , thats what i did , used all 3 banks , you can turn after touch off in the mpk249 , so the pads will work as buttons , the G button can be found in the midi map editor , best to select toggle for buttons

thanks for the help! Where do you turn off the aftertouch? Pad by Pad? Couldn’t find a way to do it in Global Settings.

to turn off aftertouch on mpk , first press edit , then press a drum pad , then go to aft: , right at the bottom of first edit page , then turn knob above cursors to turn aftertouch off , then press another drum pad and do the same thing , and keep going till you are finished . then save in mpk , ( by pressing the preset button , and then pressing left cursor , then push in knob to save .

that’s what I did, thanks heaps! I thought there would be an overall setting in Global Mode that could do the trick for all.
When you’re using the banks, are you creating a new page every time or it seems on one of your screenshots that you’ve used all three in the same script/page? How did you do that?

That’s how far I got but i’m unable to map other buttons (e.g. the Push to entre know, DAW control ones, and the control bank ones :frowning: ). Anyway, many thanks for your help, appreciate your time!!

i just use the bank buttons on the mpk eg. bank A is for my zooming rec, solo , mute etc
then i press bank B to get my quick controls and chord pads , then bank C is all , selected track EQ
for the drum pads i use bank D for my mixer , media bay , open instrument etc…
i use bank C for editing stuff and lesser used tools
i use half of bank B for chord pads in halion sonic se ( i changed them from a usb channel a10 to common in the mpk
i just use one page in the script and use the mpk bank select to switch between them . i also use DAW control cursors to change channel in the mixer and media bay and for vari audio
got it working real good , i dont use the mouse much if i can help it , good for work flow !!

i also never mapped DAW control , those buttons always worked pretty well on my system
i don’t think the push to enter button can be mapped , i think that knob is exclusive to mpk system
cheers !!