Akai MPK49 Cubase sync issues

Just bought an MPK49, loving the feel, but I’m having a few issues…

I am running Cubase LE4 on Windows Vista. The Akai MPK49 firmware is 1.05.

The main problem is that I can’t get it to sync with Cubase. For ex. when I use the Note Repeat or ARP, it sounds great while I’m recording, but off beat/out of sync when i play it back. The 16/T I just recorded does not at all sound like 1/16T when played back in Cubase. I’ve set the mode to “External” on the MPK, but I can’t seem to get the settings right in Cubase. Does anybody have a guide to how I should set up the MPK with Cubase, from scratch? This is my first time using a MIDI controller, so I may have forgotten something crucial…

I’ve been searching the web for hours but can’t seem to find anything that resolves this issue. And yes, I RTFM first. I have however found out how to fix the transport (generic remote) and automatically set up the faders using the Cubase preset on the disk that came with the MPK, but resolving the sync issue is way more important (to me).

Like I said, this is my first MIDI device ever, so any suggestion might help. What should be my MIDI in & out?, what should be the assigned timecode source? etc…

PS: I have not installed it in the “MIDI Device Manager”, as it is not listed and I don’t know how many/which channels to select. Is this necessary?

PPS: Sorry if I posted this in the wrong part of the forum, 1st post

I have an MPK25 but it has similar features to what you have.
Make sure you don’t have the “Auto Quantize” turned on. I think this sounds like your problem, but,
Also check your “Project Synchromozation Setup” settings, under Midi Clock destinations, I have mine set to:
Midi Clock Follow Project Position – ON
Always Send Start Message – ON
Send Midi Clock in Stop Mode - ON

and everything works fine,
I hope this helps

Thank you for answering!

I’ve read elsewhere that AutoQ should be on, but I’ll try it out as soon as I get a chance. I have the other options you mentioned turned on. What do you have set as midi timecode source, midi timecode destinations and midi clock destinations?

I’ve also encountered another problem: I seem to have created a new Cubase preset on the MPK49 by mistake. Both “Preset 1” and “Preset 3” on the MPK are now called “Cubase”, and frankly I do not know how this has happened or which of them is the “original”. Is there a way to reset everything, and would this be safe?

You can leave AuotQ turned on if you want, be be awarwe that you need to change it to same time division of the ARP. Otherwise if you have the MPK set to output 1/16t notes but the AutoQ is on and set to 1/8 notes, it will auto quantize everything you are trying to record to 1/8 notes, that is why it may sound different in playback.

Those other midi settings are for synchronizing external devices to Cubases MIDI or time code outputs, just leave them off. Only the “Midi Clock destinations” I mentioned are relevant for what you described.

The MPK has a Cubase preset on it for controlling pre determined settings in Cubase. These settings were made at the factory to be used as a starting point for general controls. For example the Knob K9 may be preset to control an aux send or something. I have never found any of the presets to be useful, I just make my own anyway.
I have customized all by buttons and knobs to my favorite things, If you overwite it, it is not a big deal beacuse you need to set it up manually from within Cubase anyway.
Good luck.

Thank you for helping me figure it out, it now works perfect! :mrgreen: I turned AutoQ off, seems like it did the trick. I also set the midiclock source to “internal”. This seems like the rational choice since I want the MPK to slave to the Cubase clock. For some reason Cubase LE4 does not seem to be able to send Midi clock when not playing, but I can live with that. Cubase LE4 does not seem to support MMC either, so to get the transport to work I have to set it to “CTRL” on the MPK, the MMC/MIDI setting does not work.

Regarding the preset, what had happened is that I somehow had overwritten the Live Lite preset. I managed to find the factory reset steps online, so that’s sorted out too.

I also have to more Q’s:

  1. When I have “Full level” and Note repeat on, the velocity/volume of each pad is supposed to be at max, and it sounds like it is. But while recording in Cubase (main window), the graphics that display recorded audio look like a Richters Scale, even though I’m only recording one drum sound with full level and note repeat. Is this correct? Esp. the first note i record is always displayed as way “louder” than the others.

  2. I have enabled the “ticker” and pre-count, but I get no pre-count… Do I have to adjust a setting on the MPK49?


    Again, thanks so much for the help!

As far as Question 1, there are many different settings that affect the view, if you can post a picture here.

Question 2: here is an image of my metronome settings, make sure you have click and pre count enabled on the transport:

The pre-roll suddenly works now.

As for the velocity question, I attached two files. They show a recording of one single drum, with Full level and Note repeat turned on. See how it starts out “louder” and then evens out in the first picture (Cubasepic1)? Why is this? The second picture (Cubasepic2) shows that velocity in fact seems to be even, but to me that seem contradictory to the first image.

Edit: oops images got kinda big, and they’re in the opposite order haha

Edit 2: I might add that these “uneven” waves also show up with only the Full level turned on, and the note repeat turned off. It seems kinda random. Sometimes when I also might not hear a certain drum when triggering it (but it is in fact recorded), and plays back fine after recording…
cubasepic2.jpg
cubasepic1.jpg

Yea the MIDI display is sort of a mystery to me as well. The only thing I can figure out is that is showing ALL midi data being recorded not just Velocity, you can turn this off in Preferences, under Event Display - MIDI - Show Controllers on/off.

Yeah okay. Thanks for all the help man, it’s appreciated

No problem, I hope it all works out for you.

Hey Guys.
Your info solved my problems too. So huge thanks! Just wanted to let you know that!
Nice!