Aligning large time signatures in Engrave Mode

I’m manually aligning large time signatures above the top staff. Is there an easy function to align? Is it normal for crosshairs not to appear for this as they do for dynamics or tempi? Perhaps a missed a setting.

Have you tried setting the Engraving Options to suitable values to avoid having to do this manually?

Ah, didn’t know about that, thanks. I’m finding the default actually quite good as long as there are no disruptive elements (like high notes or ties) in the top staff. So this would just invert my problem. More adherence to global formatting options is definitely a goal of mine…thanks again.