All midi tracks play at once

Hope someone can help me out here.

I’m using Cubasis 3.3.3, iOS 15.

I use a korg microkey air Bluetooth to play midi instruments in Cubasis.

Right now, the keyboard plays all the midi instruments at once, except the one I am trying to play.

Let’s say I’ve got these midi tracks set up:

  1. Sampletank
  2. Microsonic
    3 korg module pro

I want to play some piano through module pro. So as usual, I connect the microkey, and select the module track.

When I play a note on the keyboard, I get sound from microsonic and Sampletank simultaneously, but not module.

I’ve tried going into the midi routing options, but they don’t seem to change anything - and I’ve never had to alter them before, no matter how many midi tracks I had set up.

This issue started when I updated the iPad to iOS 15.

Hope someone can help! Thanks!

Hi @suddenthump,

Thanks for your message and a warm welcome to the Cubasis forum!

Please double check, that only a single track is record enabled, showing the red marked button in the track list and/or the mixer.

Or could it be, that you’ve changed the status of the “MIDI Input Only for Armed Track” option located under Setup/MIDI?

If the problem persists, it might help to fully shut down and restart the iPad and re-connection the MIDI device before trying it again.

Please let me know how you proceed.

& stay well,

Hello Lars, thank you for the reply and the warm welcome!

I have tried all the things you suggest. Only one track is record enabled, and I have the arm only selected track function on. I have turned the iPad on and off, and reconnected the keyboard several times. No luck.

In desperation, I toggled some of the Mackie HUI settings on and off. I don’t even know what these are! But inexplicably, that has fixed the problem.

I’m not wild about this as a result, though, because I know this will happen again and I have no real idea what I did!

Scratch that - the inexplicable solution didn’t last. I’m back where I started.

Hi @suddenthump,

Thanks for your message.

Is it possible that you changed the “MIDI Input Only for Armed Track” option located under “Setup/MIDI” at some point, leaving to that status?

Would suggest to give the following steps a try in this order, as well:

  • Load the “New Project” template
  • Close all running apps, including Cubasis
  • Fully shut down the iPad, and disconnect the hardware

Afterwards relaunch the iPad and Cubasis, and reconnect the device.

Does this help to resolve the problem?