All tracks respond even if only one track is selected

I have Cubasis 2.8.6 for iOS. If I want to create a piece of music and record several different tracks (eg piano in 1st track and some keyboard sound in 2nd track and maybe organ in 3rd track), then all tracks play, even if I have only selected one track. Ie. that when I want to record, for example, drums on the 4th track, then the other three tracks also play. It seems very annoying that I can hear piano, keyboard and organ when I play a drum sequence on the midi controller.

I do not experience this in any of the other DAW’s, such as. FL Studio Mobile or iOS 'own Garage Band.

My MIDI controllers are M-AUDIO OXYGEN PRO MINI and ARTURIA Keystep 37.

I do not think this is particularly appropriate as it is confusing that the piano track also responds with a “C” sound when I press the “C” key down to want to play e.g. a snare drum sound.

All the other tracks also responds simultaneously to the same “C” key.

What did I forget to set. I do not seem to be able to find options to adjust this so that Cubase responds like most other DAWs?

Is there anyone who can help me?

Hi @Skaevbar,

Thanks for your message.

Am I right, that you use Cubasis alongside with an external controller device to trigger the keys?

If so, please check if changing the status of the “MIDI Input Only for Armed Track” option, located under “Setup/MIDI” resolves the problem.

Hope that helps!

Stay safe
& best wishes,

Hello Lars,

Thank you very much for your answer. I was so lucky to make it work yesterday morning.

I simply tried and tried and eventually succeeded. But I was not quite aware of what I did before reading your email. Now I understand it better.

So thanks again for your reply. It is appreciated.

I’m using a Aturia Keystep 37 and a M-AUDIO OXYGEN MINI alongside Cubasis.

Best regards

Sendt fra myMail til iOS

Hi @Skaevbar,

Thanks for your updated message.
Glad to hear that everything works as expected again.

Enjoy making music
& stay well,