all tracks sounding when using keynote editor

hi
when i have all tracks on view in keynote editor [pno roll]
all instruments sound when i play keyboard , cant work out how
stop this happening , just want to hear the instrument i am writing for
selecting relevant track in project view means all the other tracks are not visible in key editor
cant find answer in steinberg help
any idea
cheers phill

In projectview, when you select a track, it becomes «armed» for recording. If you select all tracks they will all be armed. If you only select the events (midiclips) you want to see, then they will show up in the pianoroll. And only the 1 selected track will be armed and sound when you press keys on the keyboard.

hi david
iam new to cubase’ when i select midi clips in project view
by lassoing with arrow tool all tracks become armed
according to what i read in online help , in preferences,
i have unticked enable record on selected midi track…this works ,but you then have to enable
manually and highlight monitor button to hear this is a lot of sodding about
i must be doing something wrong i have read key editor section in manual and cant find
another way
cheers phill

I checked every possible situation works fine!!

the only way that this is happening, when you have different tracks, with the MONITOR button ON (right from the red record button)

BE SURE THAT NO MONITOR BUTTON IS ON

Select a Track, mark 1 or more parts to edit

Open the Key Editor

Now you hear only the select Track

Switch to another Track , no you only play/hear that (midipart) >>>> or use CURRENTLY EDITED PART (check this box must been vissible) (you find it right from the Quantize (functions) Button…

Good luck

Regards
Delphi

Hi delphi
What do you mean by
mark…parts