All voices in choral piece are played legato except bass voice

I’m working on a four voice choral piece. I have each player set to use the [GM 053] Choir Aahs sound and use the same channel in HAlion Sonic SE but for some reason though the bass singer gets played back differently than the other voices. In Play mode I see that the bass players notes are cut off just a bit before the full duration of the note while the other voices’ notes are played for the full duration. From what I can see all the voices are set to playing technique Natural but I’m not really sure if that affects it or how I would change that. I’ve provided a screenshot of the play tab which shows a simple D scale added in each voice and how the bass is different from the others.

Is there any way to solve this? Is it possible to change how the default setting of how notes of a player in Dorico are played back?

I think you might be running into problems because you have all players routed to the same channel, and some of them share the same notes. MIDI devices don’t usually respond very well to multiple notes at the same pitch at the same time, and this may create the effect of lengthening them. If you have them routed to different channels then I think you may see the more correct behaviour. The legato playing technique gets automatically added to the notes under a slur.

Hmm, okay. You’re definitely on the right track but I think I may have stumpled upon some kind of bug here. As soon as I changed all voices to have one channel each they all turned to the expected non-legato playback. As soon as any two voices share the same channel though all players except the bottom one sharing the same channel plays everything in legato, not just note sharing the same pitch. For example if I set both tenors and altos to share channel 2, altos would play legato and tenors wouldn’t. If I’d then put sopranos on channel 2 aswell both sopranos and altos would play legato while tenors kept their non-leg playstyle.

Is there a way for me to manually set playing technique in the Play tab? Right now I would prefer the legato playstyle everywhere but it feel tedious having to but a Flow-wide slur for the project.

No. But you might achieve what you want in Playback options (cmd+shift+P / ctrl+shift+P) -> Timing.

Great, that solved it for me. Thanks!

Basically if you have multiple instruments sharing the same channel and they play some of the same pitches, as in your example, then all bets are off, because Dorico has to do extra processing to resolve these multiple notes (if we didn’t then the plugin would stop at the end of the first note if you have 2 overlapping notes at the same pitch and same channel). I would strongly recommend using separate channels as it reduces the chance for surprises. There’s really no downside to doing so.