Allen & Heath Zed R16 Generic rmt and MMC transport controle


I’m currently trying to set up my A&H Zed R16 to operate a few MIDI controller functions with cubase and I’m not having much luck getting it to operate the transport functions.

I have set it up as a generic remote and have the faders on the R16 operating faders in the mixer within cubase and have successfully assigned a few buttons to change workspaces. But I cannot seem to get the R16 to work as a master to initiate transport functions within cubase 5.

I have gone into Transport / Project Sychronization Setup and under Machine Control Input i have ticked the MMC Slave Active, selected the ZED R Port 1 as MMC input, have the device ID as 127 which cubase picked up. But it doesn’t trigger the transport controls. I don’t get any MIDI activity showing in the transport bar when i press the transport buttons on the R16 either - but i do when pressing any of the other MIDI mappable buttons, but this could be because its transmitting MMC rather than MIDI?

I know that the R16 is transmitting the relevant MMC signals as i tested it in Logic by setting it up as an MMC master device and it worked straight away - so it must be some setting in cubase that I’m missing?

Any help greatly appreciated.

BTW running on mac pro OSX 10.5.8 - Cubase 5.5.2

I just tried to setup the MMC transport control using a ZEDR16 with Cubase Studio 4 for a friend which didn’t work! I can go into the transport control dialog box and activate the control but it doesn’t stay set!
The MIDI control faders all work fine but the transport controls using MMC do not.
In the manual it does say (Cubase only).
Does this mean that Studio 4 does not permit setting up MMC transport control functionality and if that is true why is that a feature disabled in Studio 4 ???
What reason would that feature at that tier software level be something not available??
I don’t see how that can be such an important feature to only be allowed in the full version, but maybe there’s a reason. Seems pretty weird…
maybe there’s a workaround some here knows about I don’t know. My friend was kind disappointed with his decision to get the ZEDR16. Typical upgrade problems I guess when you buy lower tier versions!
I have recommended my friend upgrade his Studio 4 to Cubase 6 full version for $200 but it’s a hard sell for just getting that feature to work properly!?

Well, acording to the manual, MMC Slave mode is Cubasse only, MMC Master according to the manual is both.
Though I don´t really understand, why you need to use MMC and don´t simply use the generic remote protocol for controling Cubase´s transport…?

Thanks thinkingcap for the reply…
Here’s the excerpt from the Manual:

“Cubase as MMC slave (Cubase only)
This is set up in the MIDI Machine Control Slave section.
Simply specify the MIDI ports and the MMC Device ID.
Some mixers support the MMC-Master protocol for controlling
external devices, including Tascam DM-24, Yamaha
DM2000 and SSL. This means that Cubase can be used
as a “recorder”, where track arming and transport commands
can be sent from the master device. In addition,
some digital audio workstations (DAWs) can only operate
in MMC-Master mode.”

So my friends trying to integrate his Allen & Heath ZEDR16 to Cubase Studio 4 and I’m afraid the (Cubase only) is why this is not working.
It is setup as “Generic Remote” and in fact all of the “CC” message type fader’s work perfect. It just won’t recognize the “MMC” message transport control.
I had him reset the ZED MIDI channel to the default CH16 but that did not change anything.
I have the same ZEDR16 using full version Cubase 6 and everything works just fine, so it’s not the ZED or Cubase.
I’ve suggested my friend cough up $200 for the C6 full version upgrade and I’ve convinced him he’ll be very happy with this upgrade as I am…so we’ll see what happens when he gets it…
At this point I’m more curious why that particular feature was disabled in Studio?..LOL.
These are the kinds of things that make me always purchase full versions of software!!

Klanky Im having the same problem…did you overcome it if so how??
Need all the help I can get buddy.


Had the same problems, eventually figured out this:
The Zed R16 defaults to midi channel 1 and MMC id 112.
So if the mixer is set to ch1 (which it probably is if you haven’t changed channel), then you need to set mmc id to 112 in cubase synchronization setup->mmc slave.

if the zed R16 is set to midi ch 2, then mmc id is 113 and so on up to ch 16->mmc id 127.
id 127 is apparently “all ids”, so if you want to control something where you can’t set the mmc id, like my mpc1000 with jjos for example, then you must use mmc id 127 and thus have to set the mixer to ch16.

Also, the settings for midi channel stated in the zed R16’s manual (near the end, one of the last pages) seems to be wrong, according to the chart button 1 is supposed to set it to channel 2 but when I tried it set it to channel 9…

MIDI-OX is a great freeware midi monitor to figure out what’s going on, i recommend installing that.
There are other monitors but not all of them show sysex which is needed for mmc messages to show up.

Good luck.