Alt-key to suspend linking a really bad idea?

Why oh why did Steinberg decide on the Alt key for this very useful function? I’ve just been in the eq for one of two linked channels. Try this:

[Edited to clear a few imprecisions up]

Open the mixer and make sure the eq curve is visible in the rack.
Fully link three channels, select and open up a channel edit window. All the following are from within this window.

Exhibit A

  1. Grab an eq point and move it around. You will see the eq curves of all channels adjust accordingly.
  2. Now hold down Alt, as if you wanted to adjust the frequency only. But because Alt suspends linking, this adjustment now only happens on one of the eqs!

Exhibit B

  1. Click to bypass the eq of one of the linked channels. All bypassed, as you would expect.
  2. Alt-click to reset all linked eqs. All linked eqs go flat. BUT… Only the eq you clicked on is in fact reset. The others appear to be simply bypassed, with the un-reset numbers still visible (but grey). Maybe because Alt-click - of course - suspends linking.

This latter behaviour may be why, after quite a bit of investigating things, the eqs are now hopelessly out of sync, at least as far as gain goes. All three have now developed independent gain offsets, so moving a point causes gain and frequency to adjust together but the gains are not properly synched - I have a big peak, a middle-sized peak and an upside-down peak. I’ve tried several resets - including doing each individually - but it won’t sort itself out.

Exhibit C - This perhaps only for Windows

  1. With the mixer showing, Alt-Tab away from Cubase to another open application. Note that Sus lights up!
  2. Alt-Tab back, let go and notice that Sus is still on.
  3. Press Alt again and it goes out.
    Simple enough - but only once you’ve spotted it!

That’ll do. I’m not sure what I’d suggest as an alternative, given that any modifier key is likely to cause a similar problem, but I’m sure one can be found (or set up as a KC).

Windows 7 Home Premium 64-bit
Cubase 7.5.30 64-bit

THANK YOU!!!

I finally found this while doing a search and it explains some of my problems!!!

Why on earth can’t Steinberg reps just chime in and respond to these things???

They do but I suppose they haven’t noticed this one, maybe because you’re the only reply. Personally, I think it’s a no-brainer that it just has to go as I don’t think there’s a workaround.

I was thinking about exactly the same thing the other day. It took me a whole lot of nerves trying to eq some linked tracks, only to find that the sound was not consistent throughout the song because of this option that makes no sense.

It would make sense if these options were consistent for all the linked tracks, but this just someone has to warn you about or else you’re in for a few hours of pure frustration.

I wonder if they rectified it in the v.8.

I’ve tidied up the OP a bit but still to solve the gain offset issue.

This thread has now been approved for the Issues section: http://www.steinberg.net/forums/viewtopic.php?f=230&t=71439#p412319

But let’s keep everything together on this one…