Always Reverb

when I touch my microphone , I have a reverb
There is no reverb with any vst or whatever

I have a Steinberg UR22C soundcard

How can I get rid of this reverb?

Thank in advance for helping


Is there any Reverb setup in your dspMixFx UR Control Panel by any chance?

1 Like

No reverb on DSP but I’ve just noticed that it also happen when my computer is off …

Well, then it has to be the reverb in your DSP - if no other component is involved.

Cheers, Ernst


Ive had this and it is the UR 22C. Double check the control panel for it and turn off or zero the reverb.

1 Like

Finally It was the reverb with the DSP , just where REV-x is written
Thank you very much for helping

I don’t know what to do with this DSP Mix Fx on my PC because I believe that this DSP only work with Ipad or iphone … I am a bit confused with this