Am I eligible for Halion 6 crossgrade with Kontakt 5 license?

Am I eligible for Halion 6 crossgrade with Kontakt 5 license? or do I need Kontakt 6?

I can’t see anything specifying a minimum version number of a qualifying application for this crossgrade. As such, I believe your Kontakt 5 is sufficient.

If you want to buy in the current sale, i would go ahead and submit an order for validation. If validation fails because it has to be Kontakt 6 to qualify, you should hear in plenty of time to order HALion 6 full version at 50% off before the sale ends on 24 February.