Amped Elektra Authorization

I had it authorized on a Mac mini.
Does not show up in the activation manager.
How do I migrate to new Mac?

Hi,

Can you see it in your products in your MySteinberg account, please?

Only Cubase showing up.

Hi,

What happens, if you try to activate it at the new system then?

Message about being activated already.

Amped Elektra still uses the eLicenser system. You can check your registered eLicenser licenses here:
https://o.steinberg.net/en/mysteinberg/my_products.html

If you don’t see Amped Elektra, please run the eLicenser Control Center on your Mac Mini and select “Registration” using the menu at the top.

Once the eLicenser is registered to your MySteinberg, perform the Reactivation process to transfer the license to your new computer:

Note that if your license was activated using an USB dongle, you have to keep the dongle connected to your computer. The Reactivation process is only valid for licenses stored in a system drive (Soft-eLicenser).

1 Like

Yes, I don’t see Amped Elektra on my e-licenser. But seems that it’s already used… And honestly don’t understand how I need to fix it now… When I select “Registration” using the menu at the top my number is smaller that in the Manager…

I lost Amped Elektra license after updating Windows 11.

It is still listed as registered but when I load Cubase 12 Pro,I have a message saying Licenses are missing or time limited licenses have expired.

I added this product through the Vouchers section on my Account as part of the 5 free plugins giveaway.

P.S. Do I need a Steinberg dongle to use Amped Elektra?

I’m Confused.

P.S. I tried reactivating Amped Elektra,Alto Glock ,and Electric Harmonis as these three fail to register in Cubase 12 pro.

I used the software elicensor to reactivate the plugins succesfully but they are still not registered in Cubase 12.

I think it was when I installed and activated Alto Glock and Electric Harmonics ,that those installs wrecked Amped Elektra but I have no idea how to get Amped elektra back.
In my product and LIbrary manager ,these plugins are registered and installed

I’m in a conundrum.

Is it the new Windows 11 update?

Does not work with the software eLicensor also.

I only just bought Cubase 12 Pro.