An open plea to Steinberg

For me, its simply to stop upgrading as there seems to be very little point. Cubase works, kind of, yet upgrading won’t improve that situation. So it’s a case of lots of compromises, bodges and patching things up on the fly. It’s therefore not a case of flouncing off but inevitably as other DAWs improve, I might well be tempted (especially from Pro Tools as its a DAW I already know).

The issues in that linked thread are so severe that it curtails how I can move forward with Cubase. I’ve started another thread to improve Track Presets, as that might be an alternative option to the buggy Track Archives and Multitimbral disabled tracks. Currently the functionality is so poor its not a contender, but if they were significantly enhanced (and reliable) I’d throw my eggs in that basket.

I’ll look up your thread on Track Presets.

Is there no way to work so as to avoid whatever problems you’re having? Given how much the program does, isn’t there another workflow pattern you can establish so you don’t hit these problems? I’m not suggesting there is but wondering if there is?

Anyway, I understand that uncovering an issue in the process of work is upsetting. You think something is working and should work, but it does not. I’m just glad these kinds of problems don’t require bringing in a different tape recorder or finding time in some other location and praying the equipment there is adequate. Good luck with your projects.


Cheers Stephen - I’ll take a look at the 9.5 track handling to make sure I’ve missed nothing, but I’m 99.9% sure that Track Presets haven’t added routing info, sends, auxes etc, which is the meat of it.

The only other solution is to sort of go back in time, and keep gargantuan templates with everything loaded and ready to go. Having lived through this and got ever-more grumpy at the unwieldy beasts, I’m very reluctant to go back. As it stands, I have a few different templates all based on the same core modular framework, and in each case I’ve fixed all the bugs as far as I can so starting off at least I’m fine (and its a delight to have such light templates). It’s when it comes to adding parts that things can get sticky, but there’s usually a fudge through somehow.

You might have an alternative to gargantuan templates. It’s not as convenient but have you tried File>export>selected tracks? Then File>import>track archive? It’s not as convenient because you are not loading inserts into an existing selected track but instead opening a new track with inserts, send and corresponding FX track.

IIRC this will/should save the inserts with sends, routings, group, and fx tracks. Please let me know if it does not with a repro. It seems there were saving issues depending on the type of track, audio or instrument, but it’s been a while.

Track presets…only good for inserts on the selected track.

Track Archives are one of the two very things causing problems. When you re-load the archive, often the routings drop off or are scrambled. It has all the right features (except it doesn’t save folder tracks, track heights and can’t be inserted at a specific position), but it’s just buggy. Also, the results are variable - often it will work ok first time but then get increasingly erratic.

I think I have been very lucky! Thanks for pointing this out. Now I want to test again in a newer version.

It goes to show for myself that I have never used Track Archives enough or put much faith in Track Presets, Import/Export track archive, or Save/Load selected which I don’t think has ever worked with Track Instruments. Also I believe Save/Load selected requires selecting the exact number of tracks that was saved in order for the user to Load Selected tracks? Regardless, these features are what I would consider things that make Cubase “pro” as they have the potential to streamline workflow.

With 3 similar features, it becomes a bit blurred as to when to use which feature, since only track presets works correctly 100% of the time…assuming the intent was only inserts in a single track and not multiple tracks, groups, sends etc.

Tested again. I tried 4 times but couldn’t get things to screw up other than track colors heights, etc. I used 3rd party and factory tools. But there are a lot of assumptions and way too many variables to consider.

  1. How I initially create the audio, track instrument, group, and efx tracks.
  2. linked vs. unlinked mix consoles.
    3 All 4 tests, I closed Cubase, then opened it vs. a project with existing tracks and using import>track archive.
  3. relatively simple test vs. big project with dozens of sends, routings, etc

In the attachments, the only difference is the track colors.

Could anyone create a repro or is the bug always intermittent?
cubase track kexport import test 2.jpg
cubase track export import test 3.jpg

I’ve noticed some of this:

Routing gets “lost” – A is track routed to a group in the original, but when the Archive is imported the routing is lost or mis-routed. I’ve seen this and similar issues mentioned in other posts. I’m tempted to try to reproduce some of these issues and post a step-by-step analysis. This is a complex issue to describe and I’m not sure I’m the best one to attempt it. Others here are far more expert users.

I’ve found that Cubase will get the MIDI data right, but, generally speaking, lots of the more complex routing and even Patch Selection is not retained in Archives (as I wish it were). Import Track from Project seems to work a bit better.

Now, what about “Library.” I’ve not worked with that, but does that, perhaps do some of this better? The OM makes it sound like it’s more for re-using clips in projects, like tags for ads and so on, bumpers, but I wonder if its worth a look?

Not sure if this helps, but In 9.5 the multi-timbral instruments now have, I believe, actual tracks in the Project and in the Mixer for activated Audio Outputs and those tracks can now be moved around like normal tracks. In my version, 9.0.4, for such instruments those “tracks” appear only in the Mixer and can not be re-positioned. This is one reason I will update to 9.5 in the near future. (I use the MIDI tracks for creating and recording MIDI parts, but prefer to mix on audio outputs. I mostly use Instrument Track because it consolidates MIDI and Audio into a neat package).

I’ll post if I find anything potentially helpful with this.

Good testing. Nice project colors, btw.

I think the reality here is that we can expect to have to rebuild things. I’m wondering if Notepad data is imported? If it is, we’d at least have a place to keep some session/track information so that when an archive is imported, those re-build notes – patch names, effects used, routing notes, whatever – would help restore the full sound. A workaround.

Thanks! Credit to Seyoum for his well thought out color pallet.

If anyone could give export/import screenshots where things went wrong on import, (hopefully simple and not too many routings/sends) I would like to try it on my PC. Please keep all plug-ins factory plugs so anyone can attempt to reproduce.

I’m not referring to notepad, track heights, automation, folders…just multiple routings, sends, groups etc. As mentioned prior, I started with a blank project. All tracks were added with right-click in the respective mix consoles. And once Track export saved, I closed and re-opened Cubase with a blank project, then Imported.

I would love to think this is fixed, and ATM I can’t generate errors. In the past I also believe I got a few random errors, but it’s been a while.

I’m using a slightly higher Cubase maintenance update, and would like to test a bit more.

Lots to pick up on here, but since it’s all specific to Track Archives I wonder if this should be in a dedicated thread - maybe the one in issues?

But for the moment - reliably forcing errors is tricky, but it sure happens sooner or later. Opening archives into different projects is a good start to causing trouble. And it does almost seem related to time - stuff that was created yesterday tends to open nicely, stuff from 3 months ago far less so. Essentially a nightmare to debug…

Let me know, I’m happy to split/move this to create a meaningful, easy to find thread.

I, for one, am fine with this being a “Lounge” discussion unless someone can post a reproducible error. Then, that could go in “issues.”

Thanks Steve, I think moving is an excellent idea. This entire thread should not be in Lounge, but regarding the specifics of Track Archives it makes a lot more sense to get input from everyone, since most never even look in the Lounge and this is a technical issue specifically regarding Cubase.

Here’s an example, the first I called up this morning. I have a VE Pro Project for CineBrass - , using a Cubase Track Archive - . When originally loading the Track Archive, all the mid tracks were routed to output VE Pro 1, whereas infact they were saved distributed among VE Pro 1 and VE Pro 2 (this is using the VST3 instance of VE Pro where you have 8 groups of 16 channels). So to be clear - there is only 1 instance of VE Pro being used as an instrument track, but the midi is saved routed to its 1 and 2 output.

I then resaved over the original track archive (which was created on my previous but identically set up rig), and now it loads correctly routed at least. But all is still not well as you can see from the screen grab:

The screen grab only shows the last few midi tracks due to space, there are many more above this. So what you see here are the last few midi tracks at the top, then a VE Pro multi-out instrument track, showing all the outputs from VE Pro.

The first and most obvious thing to note is that phantom duplicate outputs have appeared (these are under the Cinebrass Audio folder track and are kind of translucent). They appear in some kind of random order, but otherwise mirror the real outputs below. No audio passes through these, though with the disabled tracks bug I get a very similar visual result but audio often DOES pass through those, and is duplicated. In this case they do not appear in the mixer, just the project window. I can reorder and remove these, and then everything looks ok. Again, this isn’t always the case, sometimes it either cannot be edited or it removes the real audio as well.

As is common, track heights are all over the place. The archive was saved all at minimum height, but has been recalled one up from this for the audio tracks, and one bigger again for the midi. It’s a small point and easily corrected, but another example of it being incorrectly recalled.

Again, much of these bugs are very similar to those on multichannel disabled instrument tracks, and one reason I tend to lump these two things together. The common problem concerns incorrect recall of multichannel instrument tracks - I’d hope that fixing one might actually fix both issues (the disabled tracks is now a logged issue as CAN 13042 - ). And I can’t stress enough - the specific results are seemingly random. Tomorrow I might recall the same track archive and get a different set of results. Routings might get lost again.

This is the thing that makes it so difficult to live with - you never know what it will throw at you next. The only safe recall I’ve found for the multichannel instrument issue is when saved, enabled, as part of a project.


Let’s get out our laser pointers. After reading the threads and looking at some of the examples, it seems there’s various issue with multi-channel audio output instruments in the Track Archives system.

In this video,, Chris Selim - Mixdown Online, demonstrates a very basic use of Track Archives to provide a way to insert a set of VST Instruments into an existing project, however, each of the tracks is, it seems, a single stereo output Instrument Track. All seems to work fine in the video. That may be the only really “safe” way to use Track Archives at this point.

What I’m seeing (and learning about from these posts) is there are a number of problems one may encounter with multi-out instruments.

I’d posted about this myself some time ago.

In my post, I quote from the version of the OM I was using at the time, it seems the language in the current, on-line OM is slightly different.

At the time of my post OM said:

Exporting and importing track archives (Cubase Pro only)
You can export Cubasetracks (audio, FX, group, instrument, MIDI, and video) as track
archives for import into other Cubase(or Nuendo)projects. All the information associated
with the tracks will be exported (channel settings, automation tracks, parts and events,

Now it says:

You can export Cubase tracks (audio, FX, group, instrument, MIDI, and video) as track archives for import into other Cubase (or Nuendo) projects. All the information associated with the tracks will be exported (channel settings, automation tracks, parts and events, etc.). If you select the “Copy” option (see below), a separate “media” folder will be created, containing copies of all referenced audio files.

This is a difficult issue because the erroneous results we’re getting are variable. After my post above got little attention, I kind of just let go of using Track Archives and concentrated on building Instrument Presets and Templates. I never posed this in an actual “bug report.” Perhaps I should have.

I’d like Track Archives to really work the way the Operations Manual says (or said) they do, but apparently they do not. The OM’s language about Track Archives seems to have changed a bit. In my quoted section it says “group tracks” are part of the Archive. Now, It seems the “etc.” does not include Group Tracks, nor is Routing considered part of “channel settings.”

I wonder if would be possible to create several Archives and then import them one after another to “rebuild” a multi-out instrument structure? Not sure – hunting for a workaround idea? I’d have to experiment with this idea.

Thanks for keeping this all civil and not turning it into a Cubase flame tread. I understand the frustration you have been through with this and hope it didn’t interrupt your actual work or life too much. You’ve identified some real issues that are complex and, it seems unpredictable, but will, I think, have impact on more advanced user’s work. A clear statement about what is working and what is not should be put out along with advice about how to avoid any traps or problems. I think you’ve covered a lot of that. I’d post a bug report in Issues and take it from there.

What the problem actually is is beyond me. I’d call it “the group track bug” or the “track archives bug” but this is programming and I’m not a programmer. I’m just trying to talk about what we’re seeing and asking “can you fix that?”

Cheers Stephen, and thanks to yourself from me, that’s a great summary of some of the issues I think. If we’re too group under one label though it seems that “erratic recall of multichannel instrument tracks” might best sum it up? And actually I’ve made the same mistake as you in that while I’ve discussed all this with support in relation to what is now CAN 13042, there’s not really a lot here on the board regarding it. I don’t know whether its best to try and formally widen the scope of CAN 13042, or try and get this logged as a separate issue. I strongly suspect that the problem code is common to both, and thinking about it logically is more likely to be related to something in the recall process as opposed to something in the disabling / exporting track archives.

One other way I’d thought to avoid the multichannel instrument track bug in Track Archives would be if you could do everything with Rack Instruments, but alas that doesn’t seem to be possible either - you can’t save a rack instrument with a Track Archive. In fact I think that was the reason I went down the multichannel instrument track road in the first place.

Steve, should I start a thread on this issues and get you to join these posts to it?

I think despite Steinberg is on the right track, some issues are still unresolved:

Track archives and disabled tracks.
Workspaces saves zoom and song position.
Better cpu use implementation
Render in place (mono, more options)
Expression maps (overhaul)
Generic Remote (overhaul, cumbersome to work and functions still not available)

I could go on, I remember how I made everyone crazy with me request to fix the VCA problems (arm recording the tracks), but in the end they fixed it. So I think it is healthy for us to keep hammering these issues until they are resolved, everybody wins

Given that CAN 13042 has been known for some time and no corrections for it have been issued (as far as I know), a new Issues Report might put a new light under the kettle.

If you do post something I suggest, as always, keep it very, very simple. Step by step, repeatable examples. The problem is the errors are variable and, apparently, somewhat “intermittent.”

For me, the disappointment was that Archives did not work as the original OM says (per post above). I got better results with Templates and so have been concentrating on that. I can make Archive Import and Import Tracks from Existing Project work in a general way.

As far as Track Vs. Rack I tried them both. I found that neither worked as the original OM described in terms of importing a Track Archives or Import Tracks from Project. The current on-line OM does work in the basic way the video I mentioned illustrates.

I think “erratic recall of multichannel instrument tracks” works as a topic for a new Issue Report. Might it be that the issues are with the instruments themselves? Perhaps this is something instrument companies should be made aware of if they have not been – see what they have to say? Problems do happen, it seems, with both 3rd party and Steinberg’s own instruments. The coders will have to have their own conversation about what this problem actually is and what can be done, if anything. to correct it.

NoiseboyUK’s example is too overwhelming for me to test. I think we need super simple. Even more simple than mine above. I still can’t generate any errors at the moment, even with exports saved on C9, but mine aren’t nearly as complex as multi-channel. I vaguely remember exporting then immediately importing a few random errors in the past. Therefore, I don’t think the issue has to do with a different Cubase maintenance build.

Process of elimination, what should be focused on first?

With a blank Cubase project, export then import with the current Cubase version (start very simple*, instrument tracks only, factory VSTs only gradually expand if no errors)? Just one mix console window open, and use the identical export/import method. Then very slowly add tracks, and factory VST’s. Then add 3rd party. Then start with additional sends and FX tracks. If all that goes well then try audio tracks and do the same above?

Next, do the above with an existing Cubase project?

Other ways to test? I’m guessing the issue hasn’t been fixed because it’s too difficult to narrow down.

*Simple-maybe 1 audio track with 1 insert and 1 send to an efx track with 1 insert? Ignore routing for the time being?

Apologies for derailing, and if there is enough interest, maybe this should be a separate thread combined with the other threads about the same bug?