really, it’s just a sloppy naming differentiation of different functions at parts of the program at the base long-time level of the software, if you really look at how it’s handled from a track topology perspective looking at the pop-up names:
On the track itself you have:
button toggle unfolds/folds the automation lanes of the selected track to how the user had last setup which automation lanes were visible/added… Clicking the toggle to hide, does not remove unused automation lanes/tracks.
‘Show Automation’ command is a one-way command for the above to unfold automation tracks/lanes.
‘Hide Automation’ command is a one-way command for the above toggle to fold automation tracks/lanes back into the top-level track just like the track header toggle, it does not remove unused automation lanes/tracks.
The above two commands are clearly directed at this top-level track header toggle.
Now, with that in mind, One would expect ‘Hide All Automation’ command to do the above ‘Hide Automation’ command but for all tracks. It doesn’t, instead, it is directed at the ‘Hide Automation TRACK’ button on the actual automation track header of unused automation tracks which removes them, and, it’s directed at the top-level track ‘Show/Hide Automation’ simultaneously.
This still doesn’t explain the naming and execution of ‘Hide All Automation’ command function though, because it’s not named ‘Hide All Automation TRACKS’, nor is it named ‘Hide All Unused Automation TRACKS and Hide Automation’
so my point stands, that this is either a long time unnoticed bug, or just bad inconsistent design -which either way, is an issue and not a feature request.