Annoying latency

I’ve been using Cubase since bygone and am quite used to problems and solving. But after switching to C 7.5 the audio input is totally fucked up. No matter how I set the input latency, when singing I get a half second’s delay in the headphones. I have tried different sound cards, and it’s all the same.

I assume I have done something stupid without knowing but still. If anyone recognizes this phenomenon, if there is any easy (or complicated) solution och at least a suggestion, I would appreciate it.


Macbook pro, C 7.5 CI 2+

Did you turn on direct monitoring in the device setup

Maybe you’ve turned off/disabled direct monitoring on your sound-card’s mixer?

And/or you’ve clicked on the Monitor icon on your vocal channel in the mixer or arrange page. (looks like a little loudspeaker, usually next to the record button on the channel inspector) If it’s orange, that’ll be what’s causing it, as your recorded audio is going through your CPU, along with all your VST effects.

It’s likely that your solution is just one click away…

No Direct monitoring as such on Mac unless you use Steinberg sound cards.

Most of us use the sound card’s zero latency mixing (Totalmix for RME, Cuemix for MOTU) or hardware monitoring. I haven’t monitored through Cubase for years because I can’t tolerate any latency, and I actually prefer doing it that way now. It means I can still hear the singer/talent during playback.

If you MUST monitor through Cubase, reduce the audio buffer as far as it will go without glitching (usually 64 or 128 samples unless running a lot of VSTis) and activate Constrain Delay Compensation.

ok, still confused. I prefer the steinberg sound card, as it’s somewhat more convenient in other ways. And as I mentioned, I haven’t had this problem before, so something is the matter… and no time to work this through right now, still, time will tell, in some way I will find something to do about it

have you got any insert on your headphone channel in the control room ?

I’m a loser baby - why don’t you etc…

With the steinberg sound card CI2+ the latency is about half a sec… with another sound card it’s somewhat less, the other sc has direct monitoring but still it’s bad.

With or without control room - no difference… Can’t even find any headphone channel in the control room. You see, I’m out.

well I use a ci2+ with the laptop and it’s very good on latency , have you set the asio driver to 128 in the device manager ?

Is 128 mandatory for the device??

Thanks anyway - being a grumpy old man with no brain, almost like winnie the pooh… things tend to turn out fine in the end but this… wow

no it’s not but if you go to low then you will introduce clicks and pops . and there is a complete forum section dedicated to the Ci range

OK, I’ll go to the Ci part. But, actually, I have used the same equipment during a long time and this problem is new. Most likely I have clicked somewhere I shouldn’t have clicked, and opened something I shouldn’t have opened, and done the click and the opening without being aware of what I was doing. So I don’t know.
But the clicks and pops are manageable, but the latency isn’t.

Still thanks for patient and respectful support.

with the setting on 12 you should get about 8ms latency at the worse so it should be completely useable :wink:

good luck

There have been documented problems with latency values connected with various plugins, I’m thinking particularly of the compression and mastering plugins. Have you got these running?


Wow, and I have been recording with and without compression, and I actually very seldom use the dither, and never when recording. Maybe I found a solution, in the vst-connections module, I never use the Studio tab but here the CR was “ON”. When disabling it things turned to the normal, I think. But when do I really need the CR anyways. And why latency when it’s turned on?

The mysteries move to other locations.

bingo !

Hi All

One more thought, have you checked that you are using the right ASIO driver, sometimes it changes itself to the Windows Generic ASIO in the Device Setup dialog, I know probably not but worth a mention.

Best Regards


Thanks for thoughts and advice. It’s solved. Sad to say, I don’t know exactly why but I think it was the blasted control room, can’t understand why it should have disturbed but when disabling it, the latency returned to something controllable instead of being the half second, no matter what.

Dave, such a spontaneous switch, no. But that seems like a horror, so most likely it will turn upp the other day, now that I know of the possibility. :laughing:

Bye for this time… Daniel