Annoying unpredictable crossfades (picts attached)

Situation: Two clips with a small overlapping part.
Hit Crossfade (X)
Result: A long crossfade across the entire clip on both sides of the clip that changes the length of the clips.
Is this a default setting that I am unaware of? Shouldn’t it crossfade only the overlapping part? It does sometimes, sometimes not.
Here is a before and after photo to illustrate:
Before X-fade.png
After X-fade.png
Thank you for you help.

It has always been like this.

I got used to it but it is terribly annoying.

You’ll have to make the crossfade longer.

Shouldn’t this be logged under “ISSUES”?

I’m not convinced yet that there isn’t some setting that I am not seeing.

Is it the “default crossfade” setting in the crossfade editor(s)? I thought this was for shape, not for length. Shape only would be far preferable, since there is no way to know in advance how long a crossfade should be on two audio clips. The required length is always different for different clips. When would you ever need a set, predetermined crossfade length?

If this is the case, then it is definitely an [Issue] for me.

f

f

The weird thing is:
after the crossfade is done you can make the crossfade as small as you want. But to be able to make it in the first place the overlap has to be at least 50 samples.

I can see where that would be useful— in those rare cases where you are sure that there won’t be some unwanted sound hiding beyond the edges of the clips that you are cross-fading. In post production this is pretty much never, but still, I see where you could want that feature. But surely wanting to crossfade the overlapping clips by the amount of the overlap is the more common needed functionality. No?