Annoying (visual) Mouse cursor offset in Editor

Hi Support,

I have a problem with my mouse cursor visual presentation in Cubase 10.0.40 on Windows

I am a new Cubase user btw.

The issue is that the cursor is that when I make clicks the actual click is a few pixels above the pointer itself. This makes note stamping / corrections etc. very impractical. Please see the screenshots below. (Please excuse me for the quality, I had to use a different tool to make screenshots as the windows default printscreen tool excludes the cursor from screenshots)

I dont know what causes this. I dont have this issue in other daws or in other areas of Cubase, it seems to be an editor only issue (i.e. in the rest of Cubase the cursor works as it should and it clicks right where I am pointing.

I hope this can be looked into!

Kind regards,


Hi and welcome,

I’m not sure, if I understand your problem correctly. Please, double-check the Grid settings. To me it seems, you want to insert the note out of the Grid, but Cubase snaps it to the Grid. Am I right? If this is the case, you can either change the Grid settings, or you can disable Snap (in the Toolbar).